configure mysql databse unsing jira wizard installation tool

Hi,

 

I tried to connect JIRA to my mysql database unfortunately it did not work. It shows me an error that says it doens't find the mysql connector driver.

 

I followed the documentation but there are some missing part I guess because I can't find the files to configure. I hope guys might be able to help a lost pal.

 

Regards,

 

Alpha

1 comment

Where did you put the mysql driver jar?

hi,

 

In /var/jirasoftware/jira/lib

 

The folder name is mysql-connector-java-5.1.45

Folder?  It should be a single .jar file

here is the contain of the forlder

 

build.xml  COPYING                              README      src
CHANGES    mysql-connector-java-5.1.45-bin.jar  README.txt

Right, you've missed the instruction to download the whole package and extract the driver from it, and you've just stuffed the whole lot into Jira's Tomcat.   You only need the driver from the package.  Tomcat doesn't know that the driver is just one file inside the distribution.

Hi,

 

Sorry I guess I am doing it all wrong. I did followed your instruction but i got this error back

 

Communications link failure The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.

Connection refused (Connection refused)

 

I am using this tutorial : https://confluence.atlassian.com/adminjiraserver/connecting-jira-applications-to-mysql-938846854.html

No, that's a good big step forward!  This means you've got the driver installed correctly and Jira can use it to try to connect to your database.

The problem now is that Jira is trying to reach the database server and getting nothing back.

You need to check the connectivity now.  Log into the machine you are installing Jira on and try connecting to the database server with simple network tools (they will give you more information about what is failing than Jira's database connection).  Can you ping the database server?  Trace route to it?  (tracert).  If you try telnet <host> <database port> does it come back with a response from the database server, or a refusal to connect?

Thank you. The database and Jira are all in the same server.

Ok, that should make the connectivity checks quicker and easier, but you still need to try to connect to the database locally - whatever you have told Jira to connect to, it's not responding.

sure, I am connected to the databaseSans titre 2.png

Right, so what are you giving to Jira that is different to that connection?  As Jira can't connect, and the client can, you must be giving the wrong connection details to Jira.

yes i came to the same conclusion. It might be the login and password. Or the file my.cnf that the tutorial says that has to be edited to include these parameters

 

 

  • Edit the my.cnf file (my.ini on Windows operating systems) in your MySQL server. (Refer to MySQL Option Files for detailed instructions on editing my.cnf and my.ini.)
    Locate the [mysqld]section in the file, and add or modify the following parameters:

    • Set the default storage engine to InnoDB:

      [mysqld]
      ...
      default-storage-engine=INNODB
      ...
    • Specify the value of max_allowed_packet to be at least 256M:

      [mysqld]
      ...
      max_allowed_packet=256M
      ...
    • Specify the value of innodb_log_file_size to be at least 256M for MySQL 5.5 and below:

      [mysqld]
      ...
      innodb_log_file_size=256M
      ...

      NB: This should be set to at least 2G for MySQL 5.6 and above.

    • Ensure the sql_mode parameter does not specify NO_AUTO_VALUE_ON_ZERO

      // remove this if it exists
      sql_mode = NO_AUTO_VALUE_ON_ZERO

hi,

I saw the problem of the connection. The privileges where granted on localhost not on the IP adress of the server once I corrected it, it worked. Now I am going through the configuration. Many thinks, you are really a champion and very patient. I hope to see you around in better circumstances.

I'm really glad I was able to help a bit.  Even if it was just to help you rule out some stuff so you could focus on the real problem.

Your write up of your config is great - it's not directly related to the problem you had, but it's an excellent list of things for new admins to look at if they're on MySQL.

Sure and thank you for your support. I am new here but I already  enjoy being part of the community.

Hi Nic,

 

Are you there bro. Another problem, just pop up. I manage to solve a part of it but totally lost on the last one. I wonder if you can help..... Please :)

I see you already working on the same project I just wrote you on the subject "Couldn't create your project due to an unknown error. Try refreshing the page to start again"

Comment

Log in or Sign up to comment
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

206 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you