Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,493
Community Members
 
Community Events
176
Community Groups

Setup Jira as a service on Debian-based systems

Although the Bamboo installation guide was very helpful setting up Bamboo on Ubuntu, the Jira auto-installer on Ubuntu was just missing a very tiny detail, which is setting the Jira service to auto start after a system reboot. I searched the community but couldn't find help.

I ended up learning a bit about System V and how to make a service script rc compatible: See here: http://manpages.ubuntu.com/manpages/xenial/en/man8/insserv.8.html

Then I modified the file /etc/init.d/jira to be like the following:

#!/bin/sh
set -e
### BEGIN INIT INFO
# Provides: jira
# Required-Start: $local_fs $remote_fs $network $time
# Required-Stop: $local_fs $remote_fs $network $time
# Should-Start: $syslog
# Should-Stop: $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Atlassian Jira Server
### END INIT INFO
# INIT Script
######################################

# JIRA Linux service controller script
cd "/opt/atlassian/jira/bin"

case "$1" in
start)
./start-jira.sh
;;
stop)
./stop-jira.sh
;;
*)
echo "Usage: $0 {start|stop}"
exit 1
;;
esac

 

Then I ran:

sudo update-rc.d jira enable

 

I thought I'd share that in case somebody else has the same issue.

 

Cheers

0 comments

Comment

Log in or Sign up to comment