Issue while starting the application in tomcat 8 for Jira 3.13.3 and JDK 1.8

09-Nov-2017 10:52:30.093 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener instance of class com.atlassian.jira.appconsistency.db.DatabaseCompatibilityEnforcer
 java.lang.AbstractMethodError: org.hsqldb.jdbc.jdbcConnection.isValid(I)Z
    at org.apache.tomcat.dbcp.dbcp2.DelegatingConnection.isValid(DelegatingConnection.jav

1 comment

Jira 3 does not work on Java 8 or Tomcat 8.  You need to use the supported versions of the software Tomcats 4, 5 and 6 should work from memory, which, in turn, mean you can't go higher than Java 6.

However.  Jira 3.13 is insecure and totally unsupportable.  You should upgrade it to at least 7.1 as a matter of urgency.

Comment

Log in or Sign up to comment
Community showcase
Published Wednesday in Jira

Make your Atlassian Cloud products more secure: our NEW admin security guide

Hey admins! I’m Dave, Principal Product Manager here at Atlassian working on our cloud platform and security products. Cloud security is a moving target. As you adopt more products, employees consta...

91 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you