Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

Fresh Jira Install fails with database config / bootstrap error [solved] Edited

I've just spent two days trying to figure out why a fresh Jira install wouldn't start. There was nothing relevant on google for the error message:

 

java.lang.UnsupportedOperationException: Not implemented for JIRA bootstrap time
	at com.atlassian.jira.security.login.BootstrapLoginManagerImpl.performElevatedSecurityCheck(BootstrapLoginManagerImpl.java:34) [classes/:?]
	at com.atlassian.jira.security.login.JiraElevatedSecurityGuard.performElevatedSecurityCheck(JiraElevatedSecurityGuard.java:22) [classes/:?]
	at com.atlassian.seraph.filter.PasswordBasedLoginFilter.runAuthentication(PasswordBasedLoginFilter.java:117) [atlassian-seraph-3.0.3.jar:?]
	at com.atlassian.seraph.filter.PasswordBasedLoginFilter.login(PasswordBasedLoginFilter.java:78) [atlassian-seraph-3.0.3.jar:?]
	at com.atlassian.seraph.filter.BaseLoginFilter.doFilter(BaseLoginFilter.java:110) [atlassian-seraph-3.0.3.jar:?]
	at com.atlassian.jira.web.filters.JiraLoginFilter.doFilter(JiraLoginFilter.java:77) [classes/:?]
	at com.atlassian.core.filters.AbstractHttpFilter.doFilter(AbstractHttpFilter.java:32) [atlassian-core-5.0.8.jar:?]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:192) [catalina.jar:8.5.6]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:165) [catalina.jar:8.5.6]

...

Caused by: java.io.FileNotFoundException: /var/atlassian/jira/dbconfig.xml (No such file or directory)
3430 at java.io.FileInputStream.open0(Native Method)
3431 at java.io.FileInputStream.open(FileInputStream.java:195)
3432 at java.io.FileInputStream.<init>(FileInputStream.java:138)
3433 at java.io.FileReader.<init>(FileReader.java:72)
3434 at com.atlassian.jira.config.database.AbstractJiraHomeDatabaseConfigurationLoader.getReader(AbstractJiraHomeDatabaseConfigurationLoader.java:84)
3435 at com.atlassian.jira.config.database.AbstractJiraHomeDatabaseConfigurationLoader.loadDatabaseConfiguration(AbstractJiraHomeDatabaseConfiguratio nLoader.java:49)
3436 ... 73 more

The config doesn't exist because it's a new installation. I don't know what jira is doing here but it was nonsensical.

Solution

I don't even know why I tried it but when I opened the page using an incognito window the page loads and the error isn't thrown. I assume that there is something screwed up with how cookies are handled, which I have set for other domains. Absolutely infuriating.

I just wanted to post this in case somebody else runs into the same issue.

2 comments

Ajay Solutions Partner May 02, 2018

Did you follow the DB configuration steps when installing Jira for the very first time ?

From the logs it shows that the dbconfig.xml is not found . I would recommend re-installing Jira again . Make sure you remove previous installation by removing the atlassian application & system folder ( /var/atlassian & /opt/atlassian) 

 

java.io.FileNotFoundException: /var/atlassian/jira/dbconfig.xml (No such file or directory)

The config isn't there because it's a fresh installation. I was expecting to see the guided configuration in the browser.

I've edited the initial post to try and make clear that the solution was to use an incognito browser window to avoid cookie / cache issues which seem to have caused the problem.

Ajay Solutions Partner May 02, 2018

Good to see you have a solution .

ran into the same issue, can confirm that incognity mode was required to set up a new instance

Comment

Log in or Sign up to comment
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you