Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,273
Community Members
 
Community Events
176
Community Groups

Configure Jira behind ELB

Hi, 

 

I am having hard times finiding correct configs for server.xml when I have Jira placed behind ELB. 

 

I have the following in my server.xml

        <Connector acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" scheme="https" proxyName="jira-prod.*.com" proxyPort="443" protocol="HTTP/1.1" useBodyEncodingForURI="true"/>

ELB has a listener that listens to port 443.  

3 comments

Jira is a standard web-application, you'll need to look up how to configure your ELB really, whichever one it is.

Not sure how this helps to be honest 

It can't help. 

The server settings on the JIRA side are for the service and you've followed the instructions for a proxy.  You don't need to change them more to place JIRA behind an ELB - the rest of the config, which presumably doesn't work, is on that.

Although I would consider trying it without wildcards in the proxyName to start with.

There is no wildcard in the proxy name (I removed the domain name). The problem was related to the connector's configuration I posted originally (it had no port settings). 

This is the wokring connector setting.


<Connector
port="8080"
maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"
enableLookups="false"
maxHttpHeaderSize="8192"
protocol="HTTP/1.1"
useBodyEncodingForURI="true"
redirectPort="8443"
acceptCount="100"
disableUploadTimeout="true"
scheme="https"
proxyName="jira-prod.mycompany.com"
proxyPort="443"/>

Found the problem. Connector settings had missing port which made ELB  proxying not wokring. 

It's the port settings in the ELB config.  If you're not sure what this is, you need to do a bit more training or reading, as it's not something you should be messing with unless you know what it is.

I too have jira running behind elb.

At elb I have installed certificate and prt is 443 that listen to instance port 8080 .

I just added proxy port, proxyname, scheme n secure in server.xml under connector port 8080.

Which is working fine .I hope this is good enough to have a secured site.

 

But I wanted to try instance port 8443 as well but I am not able to get proper setting might be something I am missing in server side or security group .

You don't need to think about port 8443, that's for the internals.

I know my work can be done by just adding certs at elb ,but I wanted to give different approach to build security to my management ...so finding other way as well.

If you have any link or doc or steps please do share with me.

I'm not sure what you are looking for here.

Comment

Log in or Sign up to comment