Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,296,726
Community Members
 
Community Events
165
Community Groups

App Link: "No response was received from the URL you entered"

i had configure our jira and confluence with SSL using apache reverse proxy .

Our link is working fine but when i tried to create application link than i got

following error :-No response was received from the URL you entered

 

please suggest me solution for this .

4 comments

"No response" is not the most useful of messages, but it can't give you much more than that.

When one system tried to contact the other, it sent data over and got nothing back.  That tells us that when you say "our link is working fine", I'm afraid that's almost certainly wrong.  At the very least, your link is not reachable from the other server.

Start with basics of networking - go to the server from which you are trying to create the link and try a curl or wget of the url you are using for the application link.  You should get a slightly more informative error message back, such as "can't resolve url".  A no response means there's a firewall between the two of them.  Or you might get a message that Jira is not able to translate, so it resorts to "no response"

I am having this exact problem trying to link multiple Atlassian apps together.

I currently have JIRA, Confluence and Bitbucket Server all running on a single Linux server. JIRA and Confluence are behind an NGINX proxy to enable SSL.  All three of these apps are linked using the non-ssl URLs.

I have just installed Bamboo onto a separate server.  This is a stock standard server install running as a non-root user with database on the same MSSQL server as the rest of the apps.  I have configured Atlassian Crowd authentication via JIRA and this is working fine.

When I try to add the application link from Bamboo, it finds the other apps and tries to setup the reciprocal link but this fails with the error "No response was received from the URL you entered - it may not be valid. Please fix the URL below, if needed, and click Continue."  

If I log on to the jira server via ssh and run curl -v http://bambooserver:port/ I get a 200 OK and the html is displayed.

Are there any logs that could help me work out what is stopping java from opening the URL when it works fine in curl?

Mike

I'm seeing the same issue trying to link to qTest and Miro. The URLs are valid. What's it looking for that it's not receiving back?

I know this is an old post, but this function is garbage and needs to be seriously looked at.  I have Jira on server A and Confluence on server B.  From both servers, I can open links to the other without issue.  Certs are valid. Everything from a 'user'/'client' perspective is working just fine.  This application link will not work with my other Atlassian products... Period... No active firewalls between them.  No port restrictions at all.  The servers are literally on the same hardware. SUPER frustrating because it seems that this worked just fine in older versions of the software, but since about version 8 it no longer works. I guess I'm probably complaining for no reason and to a vacuum because on-prem servers will no longer be a thing soon and because of that, we will probably be going to a new product. Best of luck to anyone having issues, you won't get any help you'll be told to "check your network" because u know... it cant be a problem with the software. 

Comment

Log in or Sign up to comment
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you