It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

Apache Proxy Forwarder

Hello,

 

I am trying to setup an Apache Proxy Forwarder to handle requests for Atlassian Applications (Jira/Confluence) that run on the same server.  Currently, we are logged out when switching between the two, and we have to manually type port numbers (e.g. 8090 for confluence) to access the application.  I've followed The Documentation for setting up an Apache Proxy Forwarder, however it's still not working.

Can anybody assist me with this?  I've posted the details of your setup below:

<VirtualHost *:80>
ServerName confluence.company.com
ServerAdmin admin@company.com

ProxyPreserveHost On
ProxyRequests Off
ProxyVia Off

<Proxy *>
Require all granted
</Proxy>

<Location /synchrony>
Require all granted
RewriteEngine on
RewriteCond %{HTTP:UPGRADE} ^WebSocket$ [NC]
RewriteCond %{HTTP:CONNECTION} Upgrade$ [NC]
RewriteRule .* ws://confluence.systemware.com:8091 [P]
</Location>
RemoteIPHeader X-Forwarded-For
ProxyPass / http://localhost:8090/
ProxyPassReverse / http://localhost:8090/

<Location />
Require all granted
</Location>

</VirtualHost>

<VirtualHost *:80>
ServerName servicedesk.company.com
ServerAdmin admin@company.com

ProxyPreserveHost On
ProxyRequests Off
ProxyVia Off

<Proxy *>
Require all granted
</Proxy>
RemoteIPHeader X-Forwarded-For
ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/

</VirtualHost>

 

 

========== Jira Connector Directive =============

<Connector port="8080"

maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"

enableLookups="false"
maxHttpHeaderSize="8192"
protocol="HTTP/1.1"
useBodyEncodingForURI="true"
redirectPort="8443"
acceptCount="100"
disableUploadTimeout="true"
bindOnInit="false"
proxyName="servicedesk.company.com"
proxyPort="80"
scheme="http"/>

 

=============== Confluence Connector Directive ============

<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol" proxyName="confluence.company.com" proxyPort="80" scheme="http" />

 

 

So we have a server let's say 192.168.12.233, and it has two Atlassian Applications: Confluence (port 8090) and Jira (port 8080).  I setup Apache on Port 80 to forward requests:

confluence.company.com -> localhost:8090

servicedesk.company.com -> localhost:8080

 

We are not using context paths, so the actual root direcotry / that is implicitly added when visiting a site, should forward to the intended port.  This will allow us to omit port numbers when entering the URI.  It was my understanding that this setup/configuration is possible; can anybody help me identify my mistake?

 

Thanks!

1 comment

If you are logged in on http://myjiraserver:8080 and then try to access http://myjiraserverTroughProxy.example.com its normal that you have to re-authenticate. 

Did you remember to change the URL of the server in General settings also?

 

-Lars

Comment

Log in or Sign up to comment
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you