issue in configuring web hook

Sunil
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 18, 2024

Configured web-hook is not receiving any updates for issues, and there is no logs to check if the webhook is working or not

 

is there any solution to check?

1 answer

0 votes
Matt Parks
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 18, 2024

I'm not sure if it works the same way in Cloud but, in Data Center, you can go to 'Logging and Profiling' under the System section and add the com.atlassian.webhooks page and set the logging level to whatever you want. This logging will be sent to the atlassian-jira.log file.

 

I would strongly recommend that you do this in a Stage environment. Partially because it's never a good idea to implement anything in Prod that you haven't tested in Stage, but also because I'm guessing there's a lot less going on in your lower environments from a logging perspective, so it will be easier to see the messages.

Matt Parks
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 18, 2024

To clarify, this is if you've set up a webhook in Jira and you want to see if it's triggering or if there are any errors. If you're talking about a webhook that is firing an API call into Jira, this won't help you at all. You'd need to look at the logs from where the webhook is being generated.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events