i am getting Error while Xray: import Result from Jenkins

atlassian_account_jira
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 4, 2024
ERROR: Step ‘Xray: Results Import Task’ failed: Unable to confirm Result of the upload..... Upload Failed! Status:500 Response:{"error":"Cannot invoke \"String.length()\" because \"\u003cparameter1\u003e\" is null"}
Notified JIRA that a build has completed (9d3241d9577d48e0b62e49426ff48295).

sample.robot

*** Test Cases ***
MyFirst Test case
Log Hello World ...

 

output.xml

<?xml version="1.0" encoding="UTF-8"?>
<robot generator="Robot 7.0 (Python 3.10.12 on linux)" generated="2024-03-04T14:47:58.941695" rpa="false" schemaversion="5">
<suite id="s1" name="sample MAR-0402024" source="/var/lib/jenkins/workspace/Xray-Jenkins_Feb-15-2024/sample_MAR-0402024.robot">
<test id="s1-t1" name="MyFirst Test case" line="2">
<kw name="Log Hello World ...">
<msg time="2024-03-04T14:47:58.959921" level="FAIL">No keyword with name 'Log Hello World ...' found.</msg>
<status status="FAIL" start="2024-03-04T14:47:58.959882" elapsed="0.000106">No keyword with name 'Log Hello World ...' found.</status>
</kw>
<status status="FAIL" start="2024-03-04T14:47:58.958489" elapsed="0.001629">No keyword with name 'Log Hello World ...' found.</status>
</test>
<status status="FAIL" start="2024-03-04T14:47:58.942389" elapsed="0.018046"/>
</suite>
<statistics>
<total>
<stat pass="0" fail="1" skip="0">All Tests</stat>
</total>
<tag>
</tag>
<suite>
<stat pass="0" fail="1" skip="0" id="s1" name="sample MAR-0402024">sample MAR-0402024</stat>
</suite>
</statistics>
<errors>
</errors>
</robot>

 

0 answers

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events