It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

hmm... we couldn't create your project due to an unknown error

Stephan Peinkofer Jul 23, 2017

I tried to create a new Project in JIRA and got the Error:

"hmm... we couldn't create your project due to an unknown error"

Looking at the logs, it turned out that non of the available resolutions match my problem.

I get the following error messages:

2017-07-24 07:59:11,842 https-jsse-nio-8443-exec-18 ERROR peinkofer 479x9125x1 16wruwr 129.187.15.185 /rest/project-templates/1.0/templates [c.a.jira.project.ProjectCreateRegistrarImpl] The handler with id com.atlassian.jira.project-templates-plugin:apply-project-template-handler threw an exception while handling a notification about a project being created

java.lang.reflect.UndeclaredThrowableException

org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "AO_60DB71_DETAILVIEWFIELD_pkey"

We run Jira 7.3.5.

 

Any ideas how to fix this?

 

Many thanks in advance.

 

1 answer

0 votes
Warren Levy Community Leader Jul 24, 2017

Hi Stephan

Only looking at your error message did I realise that you're trying to create a project via the REST API - initally i assumed it was directly via Jira.

Firstly, do the user credentials that you're using for the API call have Admin rights? Whatever you do via the API needs to have the relevant access rights. Have you tried with the same user to create a project directly in Jira?

Secondly, it would be useful to see the complete call (curl or Json) that you're using, to give others a better chance at understanding what's gone wrong.

Warren Levy Community Leader Jul 24, 2017

I just looked again at your error message and seeing "duplicate key" was wondering if you're trying to create the project by SQL to the database. If so, don't, it's definitely not the way to go

Stephan Peinkofer Jul 24, 2017

Hi Warren,

 

no, I tried to create the project via the JIRA Web Interface. Not via REST.

 

I think I now already found a solution. Seems that somehow some sequences in the datase had a wrong setting. As I incremented them to a higher value, I now managed it to create a new project.

 

This is a cloud instance restored to on-premise. Maybe that was the cause that the sequences were set to the wrong value.

Like Oleg Sklar likes this

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Jira Software

How to prevent the propagation of unused project schemes, workflows & screens in Jira software

Atlassian ranks project attributes as the third most important factor impacting performance in the category of data. It’s not surprising, since project attributes are precisely the rules used to ma...

1,378 views 1 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you