Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

error after updating to 8.15.0

Hi All,

we just updated our Jira Server installation to version 8.15.0. Now we have the following error: Everytime when the last sub-task of an user story is moved to done in the board and jira tries to set the user story to done automatically, an error occurs and the jira frontend is broke and need a refresh. The same error occurs if in the board the "Move to Done"-button of an user story without open sub-tasks is pushed. The only way to set the status of an user story to done is inside the detail-view of it.

I hope someone here can help solving this.

 

Here is the error message, that appear:

 

 

An error occurredHide…

Please try refreshing the page, or contact your administrator / Atlassian Support if the problem continues.

Details

    • Exception: Uncaught TypeError: i(...).html is not a function
    • Resource: http://entopkon:8085/s/aff62868a962146d20321f7d7966998e-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/cf8c8dd391d6f257e796e4c7a370b956/_/download/contextbatch/js/gh-rapid-work,gh-rapid-detailsview,greenhopper-rapid-non-gadget,jira.project.sidebar,jira.global,atl.general,com.atlassian.jira.projects.sidebar.init,-_super/batch.js?agile_global_admin_condition=true&baseurl-check-resources=true&flexboards=true&healthcheck-resources=true&jag=true&jaguser=true&locale=en-US&richediton=true&whisper-enabled=true
    • Line: 6834
    • Column: 301

Environment

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36

Stack trace

  • TypeError: i(...).html is not a function
  • at Object.o.showDialog (http://entopkon:8085/s/aff62868a962146d20321f7d7966998e-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/cf8c8dd391d6f257e796e4c7a370b956/_/download/contextbatch/js/gh-rapid-work,gh-rapid-detailsview,greenhopper-rapid-non-gadget,jira.project.sidebar,jira.global,atl.general,com.atlassian.jira.projects.sidebar.init,-_super/batch.js?agile_global_admin_condition=true&baseurl-check-resources=true&flexboards=true&healthcheck-resources=true&jag=true&jaguser=true&locale=en-US&richediton=true&whisper-enabled=true:6834:301)
  • at Object. (http://entopkon:8085/s/aff62868a962146d20321f7d7966998e-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/cf8c8dd391d6f257e796e4c7a370b956/_/download/contextbatch/js/gh-rapid-work,gh-rapid-detailsview,greenhopper-rapid-non-gadget,jira.project.sidebar,jira.global,atl.general,com.atlassian.jira.projects.sidebar.init,-_super/batch.js?agile_global_admin_condition=true&baseurl-check-resources=true&flexboards=true&healthcheck-resources=true&jag=true&jaguser=true&locale=en-US&richediton=true&whisper-enabled=true:6892:9778)
  • at i (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:22867)
  • at Object.fireWith [as resolveWith] (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:23648)
  • at Object.a. (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:24627)
  • at i (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:22867)
  • at Object.add [as done] (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:23187)
  • at Object. (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:24283)
  • at i (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:22867)
  • at Object.fireWith [as resolveWith] (http://entopkon:8085/s/f9e5838791c7537249dcd9c517d0af26-CDN/hmd3op/815001/6411e0087192541a09d88223fb51a6a0/c1fbc32d8901156c4fd066968f840088/_/download/contextbatch/js/_super/batch.js?locale=en-US:54:23648)

4 answers

1 accepted

2 votes
Answer accepted

We made an upgrade to Version 8.16 and the error is gone. @Anton Romm you were right

I am glad to hear that the upgrade resolved the issue! The description of the problem is related to the following bug: https://jira.atlassian.com/browse/JSWSERVER-20837

1 vote
Dirk Ronsmans Community Leader Mar 23, 2021

Hey @Jonas Tewolde ,

I'm reading around about this/similar errors and was wondering if you have any other applications installed besides JSW? 

  • Do you also have JSM or Jira Core? Were those also upgrade to the proper/compatible versions?
  • Do you have any plugins installed that still need to be updated?
  • Have you tried going in to safe mode or disabling addons temporarily to rule those out?

Hi @Dirk Ronsmans

thank you for the quick response. The plugins needed an update, but this isn't the issue. Updating did not help and deactivating all plugins didn't help either.

The save mode disables the whole board we can't test if the error still can be triggered.

We have Jira Core and Jira Software. While in the admin section "Versions & licences" Jira Core is in Version 8.15.0, for Jira Software is shown the message "Jira Software is licensed but not currently installed." This hardens your a hint, that there could be a version incompatibility. Tomorrow we will try to update to Version 8.16. I will report here if it helped or not

Dirk Ronsmans Community Leader Mar 25, 2021

Might not be about version compatiblity, sounds like the JSW is just not installed.

When you upgraded, did you use the installer for Jira Core + JSM? 

If so you could just install the app for JSW separate. It's also downloadable from the marketplace which you can then install like an app.

 

https://marketplace.atlassian.com/apps/1213607/jira-software/version-history 

JIRA Version 8.15.1 ... We have exactly the same problem.

@Dirk Ronsmans can you also confirm that this bug is fixed with version 8.16? This bug is annoying, so it should be documented somewhere.

Hi!

We have exactly the same problem!

Dirk Ronsmans Community Leader Mar 25, 2021

@Anton Romm 

Same questions apply to you then :) (see my comment on the original post)

Upgrade to 8.16 fixed this bug.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

531 views 15 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you