”XSRF check failed” when creating new projects

Wang, Lan 1 April 16, 2020

★Problem
My team installed Jira Server 8.8.0 behind an ALB in EC2(Linux).
When URL「https://cs-XXXXXX.itps.YYYYY.jp」is accessed, We can login successfully.
However, when we try to create a new project, the error below occurred:

Error creating project, XSRF check failed'

★Trials and Errors
As is suggested in the following url:
https://ja.confluence.atlassian.com/jirakb/creating-project-throws-error-creating-project-xsrf-check-failed-397083076.html
I have configured proxy server information in server.xml. However, it does not work after restarting jira service.

 $ vim /opt/atlassian/jira/conf/server.xml

<Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"

                   maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"

                   maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"

                   acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="true" scheme="https"

                proxyName="https://cs-XXXXX.itps.YYYYY.jp" proxyPort="443"/>


Any help will be appreciated! Thanks in advance.

3 answers

1 accepted

1 vote
Answer accepted
Nobuyuki Mukai
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
April 23, 2020

Thanks for posing a question in the Atlassian Community!

We've answered your question in https://support.atlassian.com/contact/#/ and we understand the problem is resolved by fixing your server.xml.   

Please feel free to contact us in https://support.atlassian.com/contact/#/  or ask in Atlassian Community if further support is needed. 

0 votes
jhenriquez October 22, 2020

I have the same problem and I can not solve it

Nobuyuki Mukai
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 22, 2020

Hi @jhenriquez 

This problem typically occurs when the server.xml setting doesn't matches with your proxy configuration. Please check the Connector directive has the right setting as  3. Configure the Connector directive . 

Also please check if 2. Set the context path is properly configured. 

I hope this helps :) 

jhenriquez October 23, 2020

Thank you, I solved the problem with your help

0 votes
Alexis Robert
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 16, 2020

Hi @Wang, Lan 1 ,

 

did you also change the Jira Base URL settings to match your url with HTTPS ? The Base URL setting for you should be https://cs-XXXXX.itps.YYYYY.jp

You can have a look here to change this setting : https://confluence.atlassian.com/adminjiraserver/configuring-the-base-url-938847830.html

 

Let me know if this helps, 

 

--Alexis

Wang, Lan 1 April 16, 2020

Thanks for your quick response. It does not work for me.
When I login as the administrator, there seems only logout option for me, as is shown in the attached screenshot.

I really need your help

screenshot 19.png

Alexis Robert
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 16, 2020

Hi @Wang, Lan 1 , 

 

you will need to ask your Jira Administrator to perform this operation then if you are not in the jira-administrator group.

Like 阿莲 likes this
Wang, Lan 1 April 16, 2020

Hey, Alexis. Actually, I am the administrator of this site. And after installation, I have registered the login user as admin. It is a little wired that the admin only has a logout option.
Could you please tell me how to reset the admin account? or any other ideas?

Alexis Robert
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 16, 2020

I'm not sure since your screenshot show japanese characters but I think this is the first screen after installing Jira, you just need to click on the first button on the left and this welcome screen will disappear. You will then have access to the Settings button.

Wang, Lan 1 April 16, 2020

I will translate Japanese to English.
Do you know any ways( CLI or GUI) to check if admin is successfully created ?

first, When I log in the site as admin, I am asked to select language.screenshot 20.png

Even after selecting English, and hit 「Continue」, still comes with Japanese(a little wired), asking select an icon. I goto next 

screenshot 21.png

Then comes the welcome page. I tried to click on the icon on the left top. but there's no reaction. All I can do is create a new project or logout. I can successfully logout. the login user is the admin. But I cannot create a new project successfully. Please help me out.

screenshot 22.png

Alexis Robert
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 16, 2020

What happens if you remove the "welcome.action" from the URL on your last screen ? it should redirect you to the Jira Dashboard.

Wang, Lan 1 April 16, 2020

if I remove the "welcome.action" and hit enter key, it goes to the following screen.
screenshot 20.png

After log in as admin, it goes to the language selection screen of my last post.
What happens with my admin user, it seems that my admin user does not have any privileges.

akshant poonia
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 22, 2024

I am also facing the similar issue, on a fresh installation. Even as a admin not having any option. and facing XSRF issue when creating a project.

Suggest an answer

Log in or Sign up to answer