We couldn't log you in

Luis Pais August 12, 2021

I'm trying to log in to jira it it keeps saying "We couldn’t log you in"
I see a 422 response in the browser's network tab:

POST
https://mgas.prod.public.atl-paas.net/analytics/event

Request:
{
"name": "jss.page.loaded.unknownJssPage",
"product": "join-site",
"properties": {},
"serverTime": 1628755273152,
"user": "-"
}

Response:
{
"error": "invalid product"
}

 

I've disabled all my extensions, cleared data for all *.atlassian domains, disabled firefox's strict protection, nothing works.

It works if I try to login in a private window.

2 answers

1 accepted

1 vote
Answer accepted
Luis Pais August 12, 2021

Looks like I missed some extensions.

If you landed here because you are facing the same problem, here's what I did:

  • Clear all you data (cookies/cache) for all atlassian and atl-paas domains (and any other domain you spot on the network tab);
  • Disable all you privacy related extensions, I had to disable all these:
    • audio context fingerprint defender
    • random user agent
    • ublock origin
    • umatrix
    • webgl fingerprint
  • Disable firefox's strict cookie protection
  • Disable firefox's https only mode

Once you are in, I think you can reenable everything (hopefully).

Peter Duijnstee August 31, 2021

Man, Atlassian nice work. Disabling uMatrix for the login page isn't enough, because it does a number of internal redirects during the login process, all of which need to be able to access 3rd party page javascript/xhr. You can't click uMatrix fast enough to disable the rules because it already redirected you to the 'login failed' page. You have to completely disable the plugin altogether just to log in.

I'm have to jump through this many hoops because it's a work requirements but if I had any choice at all I'd have stopped trying and used a different service.

0 votes
Bryant Eadon November 21, 2023

Keep uMatrix enabled.

 

What you're missing is the "Spoof referrer headers" *disabled* on the subdomain of the atlassian cloud service.

 

For example (mine) :

https://balancebits.atlassian.net/

 

I needed to disable only, "Spoof Referrer Header", and then I was able to login correctly.  Try it, leave a comment if it worked for you.

Bryant Eadon February 19, 2024

well, it stopped working.  I needed to disable uMatrix to login again.  I am not sure what is causing this.

Suggest an answer

Log in or Sign up to answer