Using multiple sites in VSCode

Ruben de Wit January 11, 2023

I am using the VSCode extension "Jira and Bitbucket" and I just discovered that the plugin got another update.
Every update I am hoping there will be a bugfix for a very annoying bug I am encountering for a very long time.

  • So I have one Atlassian account connected to my work-mail
  • This account is connected to two cloud instances / sites
  • For the extension I select one site (yellow)
  • Both sites are imported (yellow and red)
  • Issues in the extensions it's issue explorer are filtered using JQL, but twice from only one site (red double, no yellow) 😢

 Schermafbeelding 2023-01-11 231409.png

There is already an open issue in Bitbucket, but I want to draw more attention to it, especially because my company is paying for Atlassian it's products.
https://bitbucket.org/atlassianlabs/atlascode/issues/706/jira-multiple-cloud

I already tried to reverse-engineer the extension to see where the issue explorer get it's information from, so if it is needed I can supply more information about what's happening.

Also, I wanted to know if this is an account-related issue? Is this a special case? Am I the only one encountering this?

3 answers

1 vote
Scott Cochrane January 23, 2023

have not got an answer  - I see the same issue.

Ismo Soutamo May 17, 2023

This seems to work as long as I have only one Atlassian Cloud sites and before that removed authentication for Atlascode integration. As soon as I add second site then I can see only issues from one site.

I'm quite sure that this has worked earlier (+6-12 month ago) as I have worked with two Atlassian cloud sites and one Jira on prem server without issues, if I recall right. 

Daniel Friesen July 16, 2023

I have the same issue. I have delete all my filters and sites under authentication and removed most of the atlascode related user settings.

If I "LOGIN TO JIRA CLOUD" and authorize for site A. Then site A, B, and C show up in the Authentication section. And after refreshing A, B, and C show up each displaying site A's issues.

If I "LOGIN TO JIRA CLOUD" again with site B, then site B still shows site A's issues. I look in the filters and the site B section says that site B is selected even though site A's issues are being displayed.

If I delete all Authentication and filters again. Then repeat by first authorizing site B. Then site A, B, and C all show up displaying site B's issues. So it's whatever site happens to be first.

I attempted to authorize site A, delete site B, then authorize site B. But when I delete site B, site A is also deleted.

Actually now that I also logged into site C. When I delete one of the sites, then 2 of the sites are deleted, one is left behind and a "cannot get client for: Jira" error is displayed. All are gone until I reload.

Krishna Sethuraman November 17, 2023

Similarly, using the "Configure filters ..." item, when I look at "Filter Search", I see the saved filters for site A.  Then I pull down the "Select a site" menu to select site B, it indicates that it's refreshing, and then the filters from site A show up again.

0 votes
Vladyslav Piskunov
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 25, 2024

This issue is still occurring with no known workaround - anyone find a way to use this? Very unfeasible with our multi-site set up where some sites are from clients, and one is our own.

0 votes
garyj February 13, 2024

Same problem here, can not get it to work with more than 1 site authenticated, using version v3.0.10 of the extension

Suggest an answer

Log in or Sign up to answer