Using REST API, Importing robotframework test execution result (output.xml) is giving 404

Preetam Baraskar April 25, 2020

Hi,

I am trying to import robotframework execution result to execution cycle in xray using REST API. Refering the following link 

https://confluence.xpand-it.com/display/XRAYCLOUD/Import+Execution+Results+-+REST#ImportExecutionResultsREST-RobotFrameworkXMLresults

response = requests.post('https://<server>/api/v1/import/execution/robot?testExecKey=XX-15275',auth=('<user_name>','<key>'),data=xml,headers=headers)

The issue(testExecKey) menntioned is already existing in the environment. 

headers = {'Content-Type':'text/xml'}

Getting 404 

 

Tried following, 

curl -H "Content-Type: text/xml" -X POST -H "<user_name>:<key>"  --data @"output.xml" https://<server>/api/v1/import/execution/robot?testExecKey=XX-15782

 

<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><title>Oops, you&#39;ve found a dead link. - JIRA</title><link type='text/css' rel='stylesheet' href='/static-assets/metal-all.css' media='all'><script src='/static-assets/metal-all.js'></script><!--[if lt IE 9]><link type='text/css' rel='stylesheet' href='/static-assets/metal-all-ie.css' media='all'><script src='/static-assets/metal-all-ie.js'></script><![endif]--><!--[if IE 9]><link type='text/css' rel='stylesheet' href='/static-assets/metal-all-ie9.css' media='all'><![endif]--><meta name="decorator" content="none" /></head><body class=" error-page error404"><script type="text/javascript">document.body.className += " js-enabled";</script><div id="page"><header id="header" role="banner"></header><!-- #header --><section id="content" role="main"><div class="aui-page-panel"><div class="aui-page-panel-inner"><section class="aui-page-panel-content lowerContent"><div id="error-state"><span class="error-type"></span><h1>Oops, you&#39;ve found a dead link.</h1><ul><li>Go back to the <a href="javascript&colon;window.history.back()">previous page</a></li><li>Go to the <a href="/secure/MyJiraHome.jspa">Home Page</a></li></ul></div></section><!-- .aui-page-panel-content --></div><!-- .aui-page-panel-inner --></div><!-- .aui-page-panel --></section><!-- #content --><footer id="footer" role="contentinfo"><section class="footer-body">

 

 

<ul class="atlassian-footer">

    <li>

        Atlassian JIRA <a class="seo-link" href="https://www.atlassian.com/software/jira">Project Management Software</a>

 

                                    

                        

        <span id="footer-build-information">(v1001.0.0-SNAPSHOT#100125-<span title='84eb0935209574a9983e2839ed793f423c8e12fe' data-commit-id='84eb0935209574a9983e2839ed793f423c8e12fe}'>sha1:84eb093</span>)</span>

    </li>

    <li>

        <a id="about-link" href="/secure/AboutPage.jspa">About JIRA</a>

    </li>

    <li>

                        <a id="footer-report-problem-link" href="/secure/ContactAdministrators!default.jspa">Report a problem</a>

    </li>

</ul>

 

1 answer

0 votes
Preetam Baraskar May 28, 2020

I also tried with id instead of username but no luck.

Can anyone pls help

Prem Singh September 6, 2020

did you got the solution?

Kanupriya
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 4, 2024

any one got solution to this?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
AUG Leaders

Atlassian Community Events