Upgrade fails from 7.2.7 to 7.3.8


We want to upgrade our JIRA Server from 7.2.7 to 7.3.8. At the same time, we want to upgrade our MySQL 5.6 to 5.7. After the Upgrade to JIRA 7.3.8 and MySQL 5.7, we are getting an error while JIRA is starting up. The following lines are found in the atlassian-logs:

2017-09-01 17:18:00,496 JIRA-Bootstrap ERROR [c.a.jira.startup.LauncherContextListener] Unable to start JIRA. com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:PluginVersion][created,2017-09-01 17:18:00.47][name,JIRA Software Chinese (China) Language Pack][id,null][version,7.3.0.int-0135-v2r387-2017-03-06][key,tac.jira software.languages.zh_CN] (SQL Exception while executing the following:INSERT INTO pluginversion (ID, pluginname, pluginkey, pluginversion, CREATED) VALUES (?, ?, ?, ?, ?) (Column 'ID' cannot be null)) at com.atlassian.jira.ofbiz.DefaultOfBizDelegator.createValue(DefaultOfBizDelegator.java:299) at com.atlassian.jira.ofbiz.WrappingOfBizDelegator.createValue(WrappingOfBizDelegator.java:172) at com.atlassian.jira.plugin.OfBizPluginVersionStore.create(OfBizPluginVersionStore.java:43) at com.atlassian.jira.plugin.JiraPluginManager.storePluginVersion(JiraPluginManager.java:357) at com.atlassian.jira.plugin.JiraPluginManager.storePluginVersions(JiraPluginManager.java:336) at com.atlassian.jira.plugin.JiraPluginManager.lateStartup(JiraPluginManager.java:126) at com.atlassian.jira.ComponentManager$PluginSystem.lateStartup(ComponentManager.java:661) at com.atlassian.jira.ComponentManager.lateStart(ComponentManager.java:171) at com.atlassian.jira.upgrade.PluginSystemLauncher.lateStart(PluginSystemLauncher.java:56) at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postTenantArrived$4(DefaultJiraLauncher.java:182) at com.atlassian.jira.startup.DefaultInstantUpgradeManager$StartupTask.run(DefaultInstantUpgradeManager.java:139) at com.atlassian.jira.startup.DefaultInstantUpgradeManager.runTask(DefaultInstantUpgradeManager.java:55) at com.atlassian.jira.startup.DefaultInstantUpgradeManager.doNowOrWhenInstanceBecomesActive(DefaultInstantUpgradeManager.java:42) at com.atlassian.jira.startup.DefaultJiraLauncher.postTenantArrived(DefaultJiraLauncher.java:177) at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDBActivated$3(DefaultJiraLauncher.java:165) at com.atlassian.jira.tenancy.DefaultTenantManager.doNowOrWhenTenantArrives(DefaultTenantManager.java:55) at com.atlassian.jira.startup.DefaultJiraLauncher.postDBActivated(DefaultJiraLauncher.java:162) at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDbLaunch$2(DefaultJiraLauncher.java:151) at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:298) at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:194) at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:141) at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:103) at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31) at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:101) at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:149) at java.lang.Thread.run(Thread.java:745)

 Thank you for any anwsers.

1 answer

0 vote
Tayyab Bashir Community Champion Sep 05, 2017

Seems like something went wrong while updating the pluginversion table.
Did you upgraded all the installed plugins to the latest compatible version before upgrading?

You should also make sure that your licenses and add-ons are all up-to-date. Removing any incompatible add-ons before upgrading may help you avoid problems during your upgrade process. You can check the compatibility of your add-ons before your upgrade using the JIRA update check.

Which version of MYSQL you upgraded to?
MySQL version 5.7.6 which requires your JIRA user for the data base to have the References permission.
See here

Thank you for you answer.

Yes, I upgraded the installed plugins and disabled the incompatible ones before upgrading.

We upgraded to MySQL 5.7.19. The jiradbuser has already the references permission.

We also reverted the snapshot and tried it again, but the same error apears.

Tayyab Bashir Community Champion Sep 05, 2017

I think this sort of error is usually because the data being pushed is in wrong encoding.
Make sure the database is in utf8_bin encoding?

The encoding of the jira-db is utf8_bin.

Suggest an answer

Log in or Join to answer
Community showcase
Bridget Sauer
Published Mar 05, 2018 in Jira Software

Jack Graves: Real Ale enthusiast with a knack for Jira Software implementation

@Jack Graves first caught our eye with his incredible breakdown of what, in his opinion, can make or break a Jira software implementation. (Read his thoughts on this thread)! In this followup Sh...

60,944 views 4 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot