Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to create an issue in a business template

I was trying to use the business template to create a recruitment project in JIRA. I assigned myself as both the project manager and the project contributor, in addition to my default role as the site admin. However, when I tried to create an issue in the "Board", it just failed, telling me that I do not have the permission. (Please refer to the screenshots I took in attachment) Could someone tell me what could be the root cause for that?

BR,

Max

Screen Shot 2020-01-14 at 11.13.01 AM.pngScreen Shot 2020-01-14 at 11.13.11 AM.pngScreen Shot 2020-01-14 at 11.13.08 AM.png

2 answers

0 votes

You can check if you have 'Issue creation permission' using the 'Permissions helper' tool. You can access it through the global shortcuts panel: Press '.' or 'gg', then 'permission'.

Direct URL to the tool: https://<instance_name>.atlassian.net/secure/admin/PermissionHelperAdmin.jspa

Thank you for reaching out. I cannot create any issue in that new project which has no issues for the time being. Therefore, I cannot pick up a particular issue, which is a mandatory field, when using the permission helper tool to check my access...

Like # people like this

Interesting. Do you have any other business projects in the instance or is this the first one you create?

Yes I do. I have another personal to-do-list created weeks ago, using a business template. And that one's fine. I tried a moment ago to reactivate the JIRA core subscription. Now I can see both projects in the JIRA Core cockpit. However, it doesn't change the story...sadly...

Like Fernando Bordallo likes this
0 votes

Hi @max_yang ,

You need Create Issues Permission to create issues in the project.

https://confluence.atlassian.com/adminjiracloud/managing-project-permissions-776636362.html

TIM截图20200114113309.png

Hi Ollie, I tried editing the permission as you have pointed out. Unfortunately it does not work. Actually by default permission scheme, everyone with the access to the application should be able to create and edit an issue. Not sure if its a problem with the business template...

Like Lenin Raj Rajasekaran likes this

Hi @max_yang ,

Can you create Issue with the shortcut on the left?

TIM截图20200114142752.png

Hi Ollie, I tried that just now. It worked at the very beginning, sending me a congrats on having successfully created one issue. However, when I tried to click that issue in the Board, I was told that I had no permission. In while, the issue is gone...disappeared...

 

Screen Shot 2020-01-14 at 2.32.45 PM.pngScreen Shot 2020-01-14 at 2.32.49 PM.pngScreen Shot 2020-01-14 at 2.33.11 PM.png

Hi @max_yang ,

It looks like your problem is similar to the description below.

 

Why can't I see issues on the board?

If your project contains customized workflows, you might not be able to see your issues on the board. Here are the two main cases where this can happen.

1: Your project contains issues that have different workflows

For instance, you have customized a workflow for a certain issue type and you have multiple workflows in your project.

 

https://confluence.atlassian.com/jiracorecloud/working-with-boards-800712866.html

 

BTW: Please feel free to contact me wechart guanqun1982, I will add you to Chinese users wechart group.

Hi Ollie, thanks! I did not customize the workflow of the project. Neither did I apply a different workflow for the issue that I was about to create. 

Nevertheless, I think I've found the cause. By creating a business project, I need to specify the Assignee in the project setting, which is by default "unassigned" . I have no idea if this is a bug. But the logic behind is simply not comprehensive...

Screen Shot 2020-01-14 at 7.31.06 PM.png

Like Fernando Bordallo likes this

Interesting. What was the default value before you changed it to 'Unassigned'?

The default value is "Unassigned". In the drop down list, there are 2 options available, Project Lead or Unassigned. With the option "unassigned" chosen, I'm not able to create an issue. But the problem is not completely solved. I added another user as project manager. She was able to create something she could not see at all, i.e. she could create an issue in this project put up by me, but once she tried to access the issue she just created, she was told that she had no permission and issue went disappeared from her "Board". however, I am able to see all those issues she tried to create...now that's something really weird...

Like Fernando Bordallo likes this

Odd indeed. Can you open a support case for this? Our engineers might be able to shed some light on the issue you are facing: https://support.atlassian.com/jira-software-cloud/

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,469 views 22 32
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you