It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

There were errors while converting temporary attachments (JIRA 7.5.0) Edited

Hi,

I have detected that in just released JIRA 7.5.0, when we have field "Attachments" in a transition screen and we attach a file through the screen, the following message is shown in the log file.

2017-09-06 22:45:43,318 http-nio-8080-exec-3 WARN admin 1365x948x1 1olnnn2 0:0:0:0:0:0:0:1 /secure/CommentAssignIssue.jspa [c.a.j.web.util.DefaultWebAttachmentManager] Temporary attachment missing: temp1759563682597384483
2017-09-06 22:45:43,320 http-nio-8080-exec-3 WARN admin 1365x948x1 1olnnn2 0:0:0:0:0:0:0:1 /secure/CommentAssignIssue.jspa [c.a.j.issue.fields.AttachmentSystemField] There were errors while converting temporary attachments: AttachmentError{logMessage='Temporary attachment missing: temp1759563682597384483', localizedMessage='Unable to find temporary attachment.', filename='#temp1759563682597384483', reason=SERVER_ERROR, exception=none()}

In spite of the error message, the files are correctly attached to the issue. Maybe this is the reason why Atlassian didn't detect the problem before the release.

This message seems to be related with the following problem I have detected in the API of JIRA and that is preventing my add-on to retrieve attachments uploaded in the transition screen:

Method getTemporaryWebAttachment of TemporaryWebAttachmentManager doesn't return any TemporaryWebAttachment since version 7.5.0 of JIRA. In previous versions it worked correctly.

I have also tried method getTemporaryWebAttachmentsByFormToken as a possible alternative but it doesn't work too.

Has somebody experienced this problem with the new version ir JIRA?

2 answers

0 votes

Hi Fidel,

Our Marketplace team has received your issue and a ticket has been created for you here:

We will continue through there. Thank you!

Kind Regards,
Shannon

Thank you Shannon.

Hi Fidel,

Am facing the same issue.

please suggest me how to resolve.

Thanks

Bhagya 

Hi Bhagya,

Sorry, but there isn't any workaround, since it's a limitation on the API.

There is a bug registered by Atlassian with 35 votes at this moment: (JRASERVER-65939). I hope they will fix it soon.

I recommend you to vote for it.

Hi Fidel,

Thanks For you quick response, I need to know when they will provide the fix.

 

Regards 

Bhagya

Fidel,

Great following-up. Thank you for letting us know what it was in the end. 

Kind regards,

Shannon

@Bhagya M S

If you watch the ticket as well as voting on it, you will be updated as soon as a fix is available.

Thank you for your understanding.

Kind Regards,
Shannon

We have faced a similar issue where some of our users were failing to attach files on issues. The corresponding AJAX call was returning error 500 saying "Unable to find temporary attachment".

We managed to resolve it by clearing Firefox (v54) cache entirely by pressing CTRL+SHIFT+DEL, checking all boxes and selecting "All". Then closing the browser and doing it again.

We think this may be caused by our recent upgrade of JIRA from 6.4 to 7.1 where JIRA now delays some treatments on the client side via AJAX calls.

As our users rarely clear their browser's cache, it may conflicts between old data and new data related to JIRA navigation.

@Shannon Spaniol I am getting this issue in JIRA 7.9.2, tried to check the ticket 

  • JSP-398396 but it is giving error "  don not have permission to view this request raise another "

Hello Manish,

Welcome to Community! It's nice to meet you.

The ticket JSP-398396 was the ticket created for Fidel by our Marketplace team. Its contents can only be viewed by Fidel and his team.

As a result, you can see that Fidel replied that the issue is indeed a bug, and he provided that URL:

  • JRASERVER-65939 getTemporaryWebAttachment doesn't return any TemporaryWebAttachment

That bug has been resolved as of Jira version 7.7.0. As you are experiencing a similar problem but you're on version 7.9.2, then I recommend that you contact the Support team directly, or raise this as a new question here on Community. That way we can deal with the errors as you are experiencing for your current version of Confluence.

Thank you for your understanding!

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira Software

Early Access: If you use Jenkins and Jira Software Cloud, you need to read this!

The Jira Software Cloud Team has been busy working on a simple, secure, and reliable way to integrate your build and deployment information from Jenkins with Jira Software Cloud. This means you don’t...

734 views 0 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you