There were errors while converting temporary attachments (JIRA 7.5.0) Edited

Hi,

I have detected that in just released JIRA 7.5.0, when we have field "Attachments" in a transition screen and we attach a file through the screen, the following message is shown in the log file.

2017-09-06 22:45:43,318 http-nio-8080-exec-3 WARN admin 1365x948x1 1olnnn2 0:0:0:0:0:0:0:1 /secure/CommentAssignIssue.jspa [c.a.j.web.util.DefaultWebAttachmentManager] Temporary attachment missing: temp1759563682597384483
2017-09-06 22:45:43,320 http-nio-8080-exec-3 WARN admin 1365x948x1 1olnnn2 0:0:0:0:0:0:0:1 /secure/CommentAssignIssue.jspa [c.a.j.issue.fields.AttachmentSystemField] There were errors while converting temporary attachments: AttachmentError{logMessage='Temporary attachment missing: temp1759563682597384483', localizedMessage='Unable to find temporary attachment.', filename='#temp1759563682597384483', reason=SERVER_ERROR, exception=none()}

In spite of the error message, the files are correctly attached to the issue. Maybe this is the reason why Atlassian didn't detect the problem before the release.

This message seems to be related with the following problem I have detected in the API of JIRA and that is preventing my add-on to retrieve attachments uploaded in the transition screen:

Method getTemporaryWebAttachment of TemporaryWebAttachmentManager doesn't return any TemporaryWebAttachment since version 7.5.0 of JIRA. In previous versions it worked correctly.

I have also tried method getTemporaryWebAttachmentsByFormToken as a possible alternative but it doesn't work too.

Has somebody experienced this problem with the new version ir JIRA?

1 answer

0 vote

Hi Fidel,

Our Marketplace team has received your issue and a ticket has been created for you here:

We will continue through there. Thank you!

Kind Regards,
Shannon

Hi Fidel,

Am facing the same issue.

please suggest me how to resolve.

Thanks

Bhagya 

Hi Bhagya,

Sorry, but there isn't any workaround, since it's a limitation on the API.

There is a bug registered by Atlassian with 35 votes at this moment: (JRASERVER-65939). I hope they will fix it soon.

I recommend you to vote for it.

Hi Fidel,

Thanks For you quick response, I need to know when they will provide the fix.

 

Regards 

Bhagya

Fidel,

Great following-up. Thank you for letting us know what it was in the end. 

Kind regards,

Shannon

@Bhagya M S

If you watch the ticket as well as voting on it, you will be updated as soon as a fix is available.

Thank you for your understanding.

Kind Regards,
Shannon

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published yesterday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

39 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot