Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

System plugins failed to start

Edited

Running jira 8.3.3 on ubuntu 16.04

Having issues on startup on one of the jira restarts:

System plugins failed to start: We haven't been able to start all the required system plugins

We couldn't start the following plugins:

 

  • Jira Projects Plugin (com.atlassian.jira.jira-projects-plugin)
  • Atlassian Jira - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian Jira - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
  • Atlassian Jira - Plugins - Global Issue Navigator (com.atlassian.jira.jira-issue-nav-plugin)
  • Atlassian JIRA - Plugins - Quick Edit Plugin (com.atlassian.jira.jira-quick-edit-plugin)
  • Atlassian Jira - Plugins - REST Plugin (com.atlassian.jira.rest)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)

 

To fix it tried:
1. everything from https://confluence.atlassian.com/jirakb/troubleshoot-a-jira-server-startup-failed-error-394464512.html.

2. Upgraded jira from 8.3.3 to 8.8.1

3. again tried everything from https://confluence.atlassian.com/jirakb/troubleshoot-a-jira-server-startup-failed-error-394464512.html

4. Installed a new jira with the same home dir as the old one (made a copy)

Nothing did work. 
Debug plugin logs have timeout errors and jira crashes

 

2 answers

To fix- 

  1. Stop the JIRA instance
  2. Keep back up in case of JIRA_HOME/plugins/.bundled-plugins and JIRA_HOME/plugins/.osgi-plugins
  3. Delete JIRA_HOME/plugins/.bundled-plugins and JIRA_HOME/plugins/.osgi-plugins (just these two folders)
  4. Restart JIRA

Have you managed to make it work again? I have simular issue with 8.8.1, even upgraded code to 8.11 with no luck

After tons of retries and cache cleaning, and server rebooting jira finally started up. I think my host didn't have enough resources, but don't know what specific. After that, i moved jira to a more CPU powerful server and didn't experience that problem ever again 

Yes, i came to the same conclusion. Virtualisation experienced massive overload, so some machines ended up in freeze state. Moved Jira to hardware and now it works like a charm.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.8.1
TAGS
Community showcase
Published in Jira Software

👋 Looking for 15-20 volunteers to test Atlassian training content

Hi everyone! Are you interested in beta testing Atlassian University’s newest (unreleased!) training course? We’re looking for 15-20 volunteers to test our newest training course, Basic reporting...

530 views 19 25
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you