Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,513
Community Members
 
Community Events
165
Community Groups

Step 3 of Creating a Test Environment for Jira

I ran the command from step 3 on my SQL server for my Jira test database which was restored with a copy of my production database and when I run the query I get this error message:

Msg 243, Level 16, State 1, Line 1
Type next is not a defined system type.

The query I ran is:

update gadgetuserpreference set userprefvalue = cast(replace(cast(userprefvalue as nvarchar(max)),'//prod.jira.base.url/','//test.jira.base.url/') as next) where userprefvalue like '%//prod.jira.base.url/%';

I replaced both production and test base URLs as requested 

1 answer

Having the same issue. Seeing as atlassian has not responded they don't seem to care that their documentation is incorrect and affecting their customers who are trying to set up test environments.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Jira Software

Upcoming changes to epic fields in company-managed projects

👋 Hi there Jira Community! A few months ago we shared with you plans around renaming epics in your company-managed projects. As part of these changes, we highlighted upcoming changes to epics on...

14,865 views 37 49
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you