Search result is messy code in "Find a Confluence page" in JIRA

confluence 6.6,jira 7.6.1,mysql is set to utf8 . 

 

similar problem  link , hope it can be solved this time~~~

1.png2.png

2 answers

1 accepted

Hi Tom,

MySQL collation is actually on 3 levels - database, table, and column. Please use How to Fix the Collation and Character Set of a MySQL Database to check if you have any mismatch over there.

Besides that, you should also check the encoding settings. You can use the steps in JIRA Application internationalisation and encoding troubleshooting to make sure you are using the correct encoding.

Please also check if this is happening on different browsers and machines - this will rule out any specific settings on your machine.

Cheers,
Moga

This question was perfectly resolved,thank you very much.

Hi Tom, happy to help! :)

hi, tom ,how you solved this ?  i have the same problem ,but followed the guide which Muthsamy offered still not working. tks 

Tom Zhu I'm New Here Apr 17, 2018

From the Support ZIP, I can see this:

    <file.encoding>GBK</file.encoding>

Please perform the steps in JIRA Application internationalisation and encoding troubleshooting - Atlassian Documentation and let us know how it goes.

tks ,tom

i have created the support zip just now too,and found the same setting as you 

    <file.encoding>GBK</file.encoding>

but how to fix this? 

i did  the every steps  in  JIRA Application internationalisation and encoding troubleshooting - Atlassian Documentation  but still not working

and i guess this instruction is very linked  to my issue ,unfortunately ,not working .

Start JIRA with the variable -Dfile.encoding=utf-8 and -Dsun.jnu.encoding=UTF-8. See Setting properties and options on startup.https://confluence.atlassian.com/adminjiraserver070/setting-properties-and-options-on-startup-749383528.html

 

and my code in setenv.bat is:

JVM_SUPPORT_RECOMMENDED_ARGS= -Dfile.encoding=utf-8 and -Dsun.jnu.encoding=UTF-8

does anyone run into the same problem? hope atlassian can solve this entirely  

Hi Tao,

and my code in setenv.bat is:

JVM_SUPPORT_RECOMMENDED_ARGS= -Dfile.encoding=utf-8 and -Dsun.jnu.encoding=UTF-8

There should not be "and" in there. Please use the following line:

JVM_SUPPORT_RECOMMENDED_ARGS= -Dfile.encoding=utf-8 -Dsun.jnu.encoding=UTF-8

Plus if you are starting JIRA via Windows Service, then you should not be editing the setenv.sh file at all. It is stated in the documentation.

As mentioned in the documentation, can I know if you have verified that the changes actually is correct and took effect? You can refer to Verifying your settings.

Best Regards, 
Mogavenasan

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 21, 2018 in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

1,039 views 7 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you