Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Schedule Issues Permission - Unable to delete a sprint

Hello,

I'm a project admin in our JIRA setup. I also have explicit Schedule issue permissions. But whenever I try to delete a sprint, I get the following error. The funny part is, this is a completely empty sprint. Not a single issue in the sprint.

How do I fix this? I assumed having admin rights should not result in this problem (based on my reading of other complaints with this issue.

I'm also unable to use the permission helper as this issue is with the sprint and not with a specific issue. Also as I mentioned above, there are NO tickets in the sprint at all.

2 answers

0 votes
Daniel Ebers Community Leader May 13, 2020

Hi Anant,

do you use "Sprint Report" and after that the menu with the three dots? If yes, which error message are you getting?

Cheers,
Daniel

Hi  @Daniel Ebers

 

Thank you for your reply. I do use the Sprint report feature but in this case, I'm trying to delete a sprint that wasn't started. This is in our Backlog board and I'm trying to delete an old, obsolete sprint:

Daniel Ebers Community Leader May 14, 2020

Your screenshots seem not to come through here, maybe you can try to attach them again or to reflect the error you are getting?

Cheers,
Daniel

Hey Daniel,

 

Sorry about that. I keep getting an error when trying to attach screenshots.

 

JIRA Board.png

I'm using the delete option in the overflow menu. This is just for representation but I get the "Schedule Permission" error from the original post when I try to delete the sprint

I have the exact same issue. The permissions helper says I have the "schedule" issues permission but I cannot delete some seemingly empty sprints in the "sprint report" section. There must have been an error in an import to create them in the first place.

Same issue here. I try to use the Sprint report to delete old sprints, and I could remove one sprint, then I started getting the "Error We couldn't make that happen because you don't have Schedule Issues permission" response.

I'm a site administrator and I have Schedule Issues permission. 

@Mads Ravn : Check the filters for the sprint/board. Create a board which does not filter the issues by project for that sprint

In my case, someone had added a ticket from a different project in my sprint and it wasn't visible to me (due to filters) and the project that the errant issue was a part of was not accessible to me. 

 

Alternately, take a look at all the issues using the following JQL to view all the issues/tickets in that particular sprint.

sprint=<sprint id>

From here, check which ones are from a different project or possibly you don't have access to "schedule" modify and remove them from the sprint or gain access to that project.

Hi @Anant Jain - thanks.

You might be on to something. There was an issue from another project in this sprint. I moved that to the project I was trying to delete a sprint in, but that didn't help.

I still can't delete the sprint :( 

On a whim I checked every issue in that sprint for subtask, but there are no subtasks from other projects.

Like Anant Jain likes this

@Mads Ravn Which method did you use? Did you look for the issues in that sprint using the JQL query? For some reason, for me, the sprint board filter was still filtering out some issues and only the JQL helped identify the errant issue/ticket.

Unfortunately, I've not investigated or tried any other technique as my issue was resolved. 

@Anant Jain yeah, I used JQL :-/

I face the same isssue,

 

We have an obsolete sprint that was not started and when i try to delete i get the error saying

"Error

We couldn't make that happen because you don't have Schedule Issues permission."

I have the schedule issues permission and i have also removed other project tickets from this sprint and still could not delete this sprint.

 

can someone please  help!

Any more thoughts on this? I am having the exact same error. Not sure how to fix it. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

⏰ Day in the life of a Jira Admin!

Hello Community! We thoroughly enjoyed this just-for-fun conversation in the Jira Admin Group about what it's like to be a Jira Admin. For #JiraJuly, our talented designers created these graphics t...

445 views 2 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you