Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Problem with visualization of the DUE DATE field in the SCREEN

Hi, I'm new with Jira Software.

I inserted the DUE DATE field in the project Screen and associated it with all ISSUEs Operations (create, edit & view), but it is not visible when I create the issue. I have tried to insert other fields and they are displayed correctly. Can anyone tell me where am I wrong? Thank you!

3 answers

1 accepted

2 votes
Answer accepted
John Funk Community Leader Mar 22, 2021

Hi Sara - Welcome to the Atlassian Community!

It might be that the field is now showing if it is empty. 

Got to Project Settings > Issue layout and check the bottom section for fields hidden when empty. 

Hi John, thank you.

I tried  repositioning the due date field like not hide when empty from Project Settings => Issue Layout, but it doesn't work.

I am configuring the first project and I have probably made some mistakes in the procedure...

John Funk Community Leader Mar 23, 2021

While on the Create screen, can you click on the Configure fields button? 

And from there, can you click on the Where's my field button? 

Yes, on Configure Fields button I see "DUE DATE" without the flag and If I try with Where's my field button, tells me (on the Status) that "The 'Due date' field should be present on the form you are viewing".

I did a test with a friend (Jira administrator): we tried to insert the DUE DATE field in an Issue Type in one of his projects with the same method I used works!

John Funk Community Leader Mar 23, 2021

That's very strange because fields are not associated with users at all. Maybe try to clear your browser cache and history and try again. Or even try a different browser. 

I tried to clear browser cache and history, also tried a different browser... :-(

John Funk Community Leader Mar 24, 2021

Going to see if someone from Atlassian can reach out to you. 

John Funk Community Leader Mar 25, 2021

Can you share a screenshot of what you see on the create screen? Go ahead and click Configure fields first and then capture the screen that shows all of the fields. 

Ciao John!

I hope it is correctly visible...

John Funk Community Leader Mar 25, 2021

Yes, I can see it - thank you. What happens if you check the box next to it. Do you then see it on the Create screen? 

Yes, If I check it the DUE DATE field is visible in Create Screen, but I don't want that users have to do this. What I need is when they  Create an issue, they see the exact fields that I specified (also if it is not a required field).

John Funk Community Leader Mar 25, 2021

Users have the ability to decide individually what fields they see in the create screen using the Configure fields option. You can't control that. You can control what fields are even available to be used in the create process - but it will apply to all users and not just some. 

What you say is correct, but I cannot understand why by doing the same operations from another Jira Sofware account, with identical permissions, the Due Date field is visible in the Create Issue.

John Funk Community Leader Mar 25, 2021

Can you share the same screenshot with that other account? 

Here are the screenshots: the configuration is the same. Here the Due Date was entered in the same way and there wase no need to flag the boxes in Configure Fields to make the field visible in the Create Issue. It seems to take Shaw All by default.

Evviva John!!!! I think I understand the solution !!!!

In the Create Issue screen, in the Configure Fields section on top, if I click on ALL (and not on CUSTOM) I see all the fields I have entered in the Screen! And, once ALL is selected, also in the Create Issue screen related to the other ISSUE TYPES that I had configured I see all the fields! At this point I just have to see what troubles I have made in CUSTOM FIELDS !!!

Let me know if you think this is the solution.

Like John Funk likes this
John Funk Community Leader Mar 25, 2021

Yes, that would be the answer.  :-)

Thank you so much!

You are a JIRA-GENIUS!!! :-)

Like John Funk likes this
John Funk Community Leader Mar 25, 2021

Haha - thank you and you are welcome!

Like Sara Santucci likes this

Thank you John, tour answer has helped me.

Like John Funk likes this
John Funk Community Leader Dec 14, 2022

Great! Glad to hear.

Hi @Sara Santucci 

Can you verify if the permission "Schedule Issues" is granted? We ran in to the same issue today and it was because of this permission not being available for an user.

If that does not work, to narrow it down, try the following steps :


  • Click Create (for creating an Issue)
  • In the top right corner, click "Configure Fields"
  • Now click on "Where is my field?"
  • Search for Due Date (or the specific field you're looking for)
  • In the list that appears, check for the validation details which will give you a clue as to what was missing.

Hi Shiffas Salim!

It seems that I have the "Schedule Issue" permission.

If I click on "Where is my field" - Due Date - >Jira tell me that The 'Due date' field should be present on the form you are viewing.

I wonder: Could the problem be on the display of the issue type?
I mean the actual number of fields visible on the screen when I go to CREATE an issue ...
Is there a way to add a column to the issue view or to ask Jira to show 15 or 20 fields
when creating issue?

Could you please add a screen shot of the validation results you see in the Where is my field - Due Date ?


If the field is configured to show in a particular issue type and the permissions are correct, it should show up - or rather, it does show up for me.


Hi, let me know if the screenshot is correcly visible.

Hmmm, I do not see the screenshot. Sorry.

Sorry, was tied up earlier. I see you've the solution from John. Excellent.

Like # people like this

Thank you so much for answering me Shiffas!

0 votes
Guilhem Dupuy Community Leader Mar 22, 2021

Hi @Sara Santucci ,

You could check from the Project settings => Issue Layout, which is a quite recent functionality. 

Your field might be is the "Hidden" section which would explain why it doesn't appear on issues.


Let me know if this helps,


Hi Guilhem, thank you for the immediate reply! I tried the solution you proposed, from Project settings =>Issue Layout and repositioning the due date field like not hide when empty (and saving the changes of course!!), but it doesn't work. I noticed that the problem is generalized to date fields.

Guilhem Dupuy Community Leader Mar 23, 2021

Hi @Sara Santucci ,

This is weird, you could check that the field is not hidden from the custom field configuration but I don't believe that all your date type fields are hidden ...

Isn't it simply hidden under other fields in your issue view ?

Hi Guilhem, I checked in field configuration and the Due Date Field (like other Date Fields) is not hidden.

I'll try to repeat the procedure again paying more attention to all the steps.

Suggest an answer

Log in or Sign up to answer
Site Admin

Atlassian Community Events