No option to "Mark as Done" for an Epic in Greenhopper 6.1

I just upgraded to Greenhopper 6.1. I'm excited to use the new Epic functionality on the Greenhopper planning board. With this upgrade, it resurrected some long-forgotten Epics that are now appearing on the left side of the planning board. I want to simply mark them as done since they're out of date and no longer relevant, but the option is simply not there.

I checked to make sure that the "Epic Status" custom field was added to the instance properly,which it was. It says that it correctly applies to the Epic issue type. I'm not sure why the menu option is missing. Even completely deleting the old epics doesn't seem to get rid of them.

9 answers

1 accepted

1 vote
Accepted answer

Thanks to Omar for leading me in the right direction. I went into the Epic Status custom field configuration and saw that there were no options configured for it. This page: https://confluence.atlassian.com/display/GH/Completing+an+Epic indirectly mentions that the two options should be "Open" and "Done", so I took these steps:

  1. Manually added the Epic Status options of "Open" and "Done"
  2. Made "Open" the default for the future
  3. Temporarily added the Epic Status field to my edit issue screen
  4. Set the value for one of my epics to Open

After taking those steps, I then saw the "Mark as Done" option and it worked when I selected it, setting the Epic Status field to Done for that epic. I don't know why the custom field options weren't configured properly in the upgrade, but I'm very glad I figured this out. I hope this is helpful to others.

You can try to make 'Epic Status' visible on the screen then change it manually there to 'Done'. That can work as a workaround

It's working!

My two cents too: you might want to check the Epic Status field properties. I've seen a case recently when these were broken (available values were assigned to a wrong Context), and fixing that returned the Mark as Done option to the board.

TO be honest, I'm not 100% sure what I'm looking at in those settings to know what is correct. Could you help me out by suggesting what I'm looking at, what might be considered correct?

Thanks

If you mean that deletion of the epic through JIRA interface doesn't get rid of them in Rapid Boards, then you may need to do a total reindex.

Thanks for the response. Looking at it more closely, I think my issue with deleting is completely separate. I did do a complete reindex to see if it helped this issue at all and it didn't. I just filtered out my old Epics, but even new ones that I create don't have the "Mark as Done" menu item.

I have exactly the same problem. The Epic Status field is present and I've re-indexed several times but I do not see the "Mark as Done" option for Epics. I also have a number of old, closed Epic issues that are clogging up the planning board.

Did you ever get an answer to the problem?

I haven't yet solved this problem. I should obviously open a support ticket, which I'll do now. I was hoping that someone had a simple solution like a reindex, but so far nothing has worked for me. If I get to a resolution, I'll post it here.

Saw a similar question recently. Are you have Edit permission on the Epic issues? If not that menu item won't appear. If not, I would request to raise a support request.

Hi

Yes, all users have edit permissions in our setup so that's not the problem.

Thanks for the suggestion

As I suggested in one of the earlier projects, it is better may you raise a support request, as it requires to check the database.

Btw, any exceptions in logs?

We had the same problem after upgrading to Jira 5.1.8 and Greenhopper 6.1.

'Epic Name' is a custom field. For some reason, we had two copies of it. Afer I removed one, the 'Mark as Done' option reappeared.

Hello,

I am facing a similar problem.

- Only one "Epic Name" GreenHopper field available correctly

- "Epic Status" GreenHopper field is available in View and Edit screens with the 3 Default options (*To Do, In Progress and Done)

- Re-Indexing done

- Edit permissions set correctly

- GreenHopper Project Template set to use "Scrum" by default

I am still unable to see the "Mark as Done" option under the drop-down that appears.

Jira version: 5.2 Build #812

GreenHopper Version: 6.1.3.2

Reference:
- https://answers.atlassian.com/questions/114059/no-option-to-mark-as-done-for-an-epic-in-greenhopper-6-1

- https://confluence.atlassian.com/display/AGILE/Completing+an+Epic

- https://confluence.atlassian.com/pages/viewpage.action?pageId=321848105

Please suggest.

Regards,

Rahul Savaikar

I recommend setting up Post Functions as in HowTo: Track Epics in the Control Chart to make Epic Status easier for every user.

We also don't see the option "Mark as done". We have set the "Edit Issue" permission correctly. Any ideas?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Apr 22, 2018 in Jira Software

How-to setup a secured Jira Software 7.9.0 on Ubuntu 16.04.4 in less than 30 minutes

...PermissionsStartOnly=true User=www-data Group=www-data ExecStart=/opt/jira/bin/startup.sh ExecStop=/opt/jira/bin/shutdown.sh TimeoutStartSec=120 TimeoutStopSec=600 PrivateTmp=true [Install] WantedBy...

2,108 views 14 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you