Need Help with these errors

NS board - Agile Board - JIRA 
TypeError: Object.keys: argument is not an Object
at b.forEach (http://usvfre105:8080/s/c35ce271647315092bcadba5a348400e-CDN/-g9cne0/75007/b6b48b2829824b869586ac216d119363/aa6cf545ff213915ecbf1d6cdcbaa2cc/_/download/contextbatch/js/_super/batch.js

 

Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; rv:11.0) like Gecko 

 

1.png

3 answers

2 votes

This kind of JavaScript error is known to be caused by any of the following:

  • User-installed plugins
  • Script in the instance (announcement banner or issue fields)
  • Environmental configuration (Proxy/SSL)

In order for us to troubleshoot this further, could you please try to answer the following:

  1. When did it start happening? Did it ever work fine before?
  2. What changes were made prior to the problem?
  3. Is it reproducible in all browsers (IE, Chrome, Firefox) using normal and incognito browsing mode?
  4. Is it affecting all users or some users?
  5. Could you enable JIRA Safe Mode, to see if the same problem is still occurring? JIRA Safe mode will temporarily disable all user-installed plugins. Hence, you might want to schedule it during a maintenance window. This test will help us rule out if any of installed plugin causes this problem.
  6. Is it reproducible on the instance after removing the announcement banner?
  7. Please run the following SQL queries in your database and provide me with the result, preferably in table format (excel or csv)
    select * from fieldconfigscheme where description like '%<script%' OR description like '%<SCRIPT%';
    select * from customfield where description like '%<script%' OR description like '%<SCRIPT%'; 
    select * from customfield where description like '039avascript%' OR description like '%html%' OR description like '%css%';
    select * from fieldconfiguration where description like '039avascript%' OR description like '%html%' OR description like '%css%';
    
0 vote

Ben,

Can you tell us exactly what you were doing to cause the error, and which browsers you're able to replicate this in?

Kind regards,

Shannon

Hello

I'm facing the same issue here.

The Error occurs when i'm moving a Jira Subtask from "in progress" to "resolved".

This happens in ie 11 (11.0.9600.18921).

Chrome works just fine.

Best Regards

Manuel

Hi Manuel,

This is a bug Atlassian will have to fix. What version are you using? The bug seems to be affecting 7.5+.

You can vote/watch this issue:
https://jira.atlassian.com/browse/JSWSERVER-16177

Maxime

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 21, 2018 in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

1,221 views 10 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you