Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

List of Custom Fields not showing in JIRA 7.13

We just upgraded from JIRA 7.6.0 to 7.13 and everything seems to be working well except the following:  When clicking on the Administration "Cog Wheel" then Issues, then Custom Fields, I expected to see a list of all of the Custom Fields that we created in 7.6.0.  However, I see nothing.  The list is blank (see photo below).  I've tried re-indexing and restarting the tomcat service, but no luck.

Custom Fields Blank.png

Is there some setting in 7.13 that needs applied for Administrators to see the list of Custom Fields this way?

1 answer

Are you seeing the custom fields on the issues? If so, it might be a bug?

Yes, I see the custom fields on both the view issue and the create issue screens.  This version has been out since November, so if it's a bug, I haven't found any other reference to it.

Interesting. Do you have any plugins that might be causing this issue? Maybe you can try running on safe mode to quickly test?

Also, any javascript hacks gone wrong? I have seen that happening too.

I've upgraded all of the plugins that we had working in 7.6.0 and disabled those that are not compatible with 7.13.  We do have some javascript embedded in the description of some of the fields, but those all worked fine in 7.6.0.

Just tried running in safe mode and still not seeing the Custom Fields.

Could you try the developer tools in your browser?  This can often show that custom javascript is the problem (it will "leak" in the source of the page).

It's another reason we recommend never using js Jira hacks.

I am having this same issue when trying to upgrade to 7.13.  Has a solution been found yet?

I can see my custom fields on screens and I can edit manually by typing URL in directly (http://jirastageserver/secure/admin/ConfigureCustomField!default.jspa?customFieldId=10093), but I cannot see the items on the Custom Fields page like mentioned above.  Which means I can't add any new ones.

 

I don't know much about the Developer Tools in Chrome, but this is showing up, but

Uncaught SyntaxError: Invalid or unexpected token
at eval (<anonymous>)
at batch.js?locale=en-CA&spectrum=true:59
at Function.globalEval (batch.js?locale=en-CA&spectrum=true:59)
at HTMLScriptElement.<anonymous> (batch.js?locale=en-CA&spectrum=true:171)
at Function.each (batch.js?locale=en-CA&spectrum=true:60)
at init.domManip (batch.js?locale=en-CA&spectrum=true:170)
at init.append (batch.js?locale=en-CA&spectrum=true:165)
at init.a.fn.(anonymous function) (https://jirastageserver/s/260ea55f4e7d1c1abde29f4c409df5b3-CDN/e735af/713000/8c016544ec71beaeef944c786614927e/534e8d91aaa06242c83b2c88ae9a3169/_/download/contextbatch/js/atl.admin,jira.global,jira.admin,-_super/batch.js?agile_global_admin_condition=true&healthcheck-resources=true&is-server-instance=true&is-system-admin=true&jag=true&jaguser=true&locale=en-CA&nps-acknowledged=true&spectrum=true&whisper-enabled=true:334:1467)
at init.e.fn.(anonymous function) [as append] (https://jirastageserver/s/260ea55f4e7d1c1abde29f4c409df5b3-CDN/e735af/713000/8c016544ec71beaeef944c786614927e/534e8d91aaa06242c83b2c88ae9a3169/_/download/contextbatch/js/atl.admin,jira.global,jira.admin,-_super/batch.js?agile_global_admin_condition=true&healthcheck-resources=true&is-server-instance=true&is-system-admin=true&jag=true&jaguser=true&locale=en-CA&nps-acknowledged=true&spectrum=true&whisper-enabled=true:338:6662)
at init.<anonymous> (batch.js?locale=en-CA&spectrum=true:168)

 

but this was in my old instance as well where it did work. 

Uncaught SyntaxError: Invalid or unexpected token

Fixed my issues above.   Apparently there was some Java script in the description field of one of the custom fields. (perhaps from a plugin)   My field was AA_Autoheader.   

To change it:  I got into admin mode and manually went to the url below and removed the description text.  Change the id of custom field and server location accordingly.  

https://jirastageserver/secure/admin/EditCustomField!default.jspa?id=12450

Like Keith Lawless likes this

Thanks for your help everyone.  I too was able to fix this issue by removing all of the js we had embedded in the descriptions of the custom fields.  We have moved on to using ScriptRunner for any additional functionality required.

I encountered a similar problem with 7.12.3 and some malformed JS in a description field. Using the direct URL per Thomas' post above allowed me to fix the problem. 

how do you find the description field that contain JS, since I have tons of custom field

I have the exact same problem but going to the field directly does not show any formatting to remove.  So cannot solve this.  This problem is on upgraded Jira Service Desk instance that also has Admin Toolbox for Jira installed.  Do you happen to have the same?  I am thinking perhaps Admin Toolbox has caused this as it has filtered searches but it looks more like the functionality is broken in Custom Fields.  I tried everything I could think of to get it working but no luck.  Luckily this is only in my dev instance.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

5,557 views 6 21
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you