Linking Confluence to JIRA Agile

Trying to link Confluence to JIRA Agile (both are the latest cloud versions)

When in the Confluence Administration --> Application Links area, I enter our JIRA Agile URL and click on "Create Link" but am immediately presented with an Internal Server Error.

When trying to create the Application Link from JIRA it works fine until JIRA then redirects to Confluence, where I again get the same Internal Server Error. Had a look in the support doco for related issues but they mostly seemed to relate to on-premise instances or issues with Fisheye.

Any help would be much appreciated.

2 answers

0 votes
Mauro Badii Atlassian Team Mar 02, 2014

Hi Erik,

Jira Agile runs with JIRA and JIRA and Confluence in OnDemand are already linked together so there is no need for an extra configuration.

What functionality are you trying to obtain? Maybe there is another problem that needs fixing.

Cheers,
Mauro

Hi Mauro,

Thanks for your reply.

When I try to add a JIRA Report in Confluence for example, I get the error "Your confluence has not been configured to connect to JIRA. Click here to set your connection.". This directs me to the Application Links area of Confluence Administration.

Under the Application Links area in confluence, I can't see our JIRA instance. For this reason I was trying to add a link to JIRA and this is when I get the Internal Server Error.

Cheers,

Erik

Mauro Badii Atlassian Team Mar 03, 2014

Hi Erik,

Thanks for explaining.

I'd recommend requesting support at support.atlassian.com as this problem doesn't look like a generic problem and the Support Team should take a closer look at your OnDemand instance to find out what is wrong.

Thanks,
Mauro

Thanks Mauro, will do.

hi, I have exactly the same problem any news ? did you git in touch with the support ?

Mauro Badii Atlassian Team Mar 17, 2014

Hi Issam,

Erik was trying to link 2 OnDemand instances, one with Confluence and another one with Jira. Finally decided to have both applications running in the same instance as recommended.

Feel free to create a new support request if your problem is different.

Cheers,
Mauro

hi Mauro,

I did the same mistake, and resolve it by creating a confluence account diretly from JIRA instance and it works now.

Thank you.

Mauro Badii Atlassian Team Mar 18, 2014

Glad to hear you worked it out Issam. :) Thanks for posting your solution here.

Cheers!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Apr 22, 2018 in Jira Software

How-to setup a secured Jira Software 7.9.0 on Ubuntu 16.04.4 in less than 30 minutes

...PermissionsStartOnly=true User=www-data Group=www-data ExecStart=/opt/jira/bin/startup.sh ExecStop=/opt/jira/bin/shutdown.sh TimeoutStartSec=120 TimeoutStopSec=600 PrivateTmp=true [Install] WantedBy...

2,101 views 14 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you