Jira does not start. . . "Unexpected exception during JIRA startup"

To replicate error, visit: http://ec2-34-232-48-211.compute-1.amazonaws.com:8080/secure/errors.jsp

 

You'll see this error: Unexpected exception during JIRA startup. This JIRA instance will not be able to recover. Please check the logs for details

 

Can I please get assistance . . . below the logs

 

See this link for the logs of localhost.2017-12-08.log: 

 See this link for the logs of catalina.2017-12-08.log 

 

Thanks

 

3 answers

0 vote

Hi Alex,

Could you let us know what database version you are running as well as the results of the following from your server:

 

java -version
echo $JAVA_HOME


Thank you! There are many things that can cause the error you were seeing, but if you also happen to find any further errors in your logs please let us know.

Lastly, please also confirm, is this a fresh Jira install or an upgrade? What version are you running?

Regards,

Shannon

Thanks . . . using psql (PostgreSQL) 9.5.4

 

for java -version, the result is:

OpenJDK Runtime Environment (amzn-2.6.9.0.71.amzn1-x86_64 u131-b00)
OpenJDK 64-Bit Server VM (build 24.131-b00, mixed mode)

 

for echo $JAVA_HOME

/usr/lib/jvm/jre

 

EDIT: I haven't deliberately updated Jira . . .but I might have inadvertently updated.  In any case, my Jira version is 7.3.5

 

thanks!

Hi Alex,

It seems you're using OpenJDK which is not supported.

You will want to install Oracle JDK 1.8 and use that according to our Supported Platforms.

Can you try that and see if you are able to start Jira?

Regards,

Shannon

thanks I'll try that

I'm having trouble finding the correct java version . . .is this version compatible?

 

http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html

 

thanks

Probably not, but it depends, check the link Shannon gave, it'll take you to the list of supported platforms.

Hi Alex,

You'll want 1.8 so you can start here:

Java SE Development Kit 8 Downloads

Let us know if you have trouble.

Regards,

Shannon

Great thanks guys will try that

0 vote

OpenJDK is not suitable for running Jira.  It does work for some versions, but it's not suported and doesn't work in most combinations.

Swap to using the Oracle (Sun) version of Java and try again.

I am now running what I believe is the correct Java version and unfortunately I am still getting the same error.

You can visit the jira instance here to see the error: 

http://ec2-34-201-47-136.compute-1.amazonaws.com:8080/

 

    $java -version

    java version "1.8.0_151"
    Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
    Java HotSpot(TM) 64-Bit Server VM (build 25.151-b12, mixed mode)

    $echo JAVA_HOME

    /usr/java/jdk1.8.0_151/jre

 

I can't really see anything in the logs:

catalina.2017-12-09.log

That log has some error about threadlocal . . .could this be it? other than that nothing jumped out

 

All of the below were empty:

host-manager.2017-12-09.log

localhost.2017-12-09.log

manager.2017-12-09.log

 

I'd greatly appreciate your continued help to get back into my jira instance . .. I'm very motivated as we have a huge project in there :) Thanks!

The error you get in the browser doesn't tell us much, but it does tell us that Jira has tried to start up and run.  In fact, it is running, because it's able to deliver that page!  Albeit it's not running enough of itself to do anything else.

There will be details of where it has fallen over in the application log.  Look in <jira home>/logs - atlassian-jira.log is usually the most important one to read.

Alex,

I'm not able to see the error now that Nic was seeing earlier on your site, but his suggestion to check the Jira Application Server Logs is your best bet.

Especially if you are to stop Jira, and start it again, you can follow along in that log file and it will let you know the exact error for why your Jira instance is now not loading.

Please feel free to let us know what you find and if you have any trouble, we can help you.

Regards,

Shannon

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 21, 2018 in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

1,205 views 10 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you