Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira JQL search for "IT" or for "NO" does not give any search result

We have a field called "Language", but searching (JQL) for some of the language codes does not give any result, while we're sure there should be.

This is no problem for for example EN, NL and PT, but it does not work for IT and NO.

  • "Language[Short text]" ~ NO
  • "Language[Short text]" ~ IT

Is this because these are actual words in English?

How can I get this working?

2 answers

0 votes
John Funk Community Leader Jan 07, 2021

Hi Helma,

Not sure if it will help or not, but you might try putting IT and NO in quotation marks:

  • "Language[Short text]" ~ "NO"

Thanks for the suggestion, but we already tried that and it did not work.

John Funk Community Leader Jan 07, 2021

Maybe try changing that value then to a 3 character

Hi Frank,

The language code only has 2 characters, so there's no 3th character to add.

I also tried:
"Language[Short text]" ~ "N?"
But this only results in the search results for NL, not for NO.

And same for 
"Language[Short text]" ~ "N*"
Also here only the search results for NL appear and not the ones for NO.

John Funk Community Leader Jan 07, 2021

The other thing might be to convert it to a single pick list custom field type. 

I'm afraid we don't have the rights in the project to do so. The fields get filled from an external application at the client's side.

I wonder why searching does work for the other language codes and not for these.
Is this because these are actual words in English?

If the values are escaped ("NO") then this should return the issues.

Can you check a specific issue via {baseUrl}/rest/api/latest/issue/<issue-key> and check the value for the Language custom field? To confirm that it really is "NO" and does not contain any other strange characters in it, maybe due to a copy or an import or something.

 

Can we also rule out that the indexes are there - can you do a project re-index and see if there's any difference in search results?

John Funk Community Leader Jan 07, 2021

They are probably some type of key word in JQL - it's not because they are actual English words. 

Try this:

"Language[Short text]" ~"\"NO\""


It looks like the text is really "NO": 
"customfield_13074":"NO"

Meanwhile I found this in https://confluence.atlassian.com/jirasoftwareserver/search-syntax-for-text-fields-939938747.html. Both "it" and "no" are mentioned in it. 

Reserved words
To keep the search index size and search performance optimal in Jira, the following English reserved words (also known as 'stop words') are ignored from the search index and hence, Jira's text search features:

"a", "and", "are", "as", "at", "be", "but", "by", "for", "if", "in", "into", "is", "it", "no", "not", "of", "on", "or", "such", "that", "the", "their", "then", "there", "these", "they", "this", "to", "was", "will", "with"

Be aware that this can sometimes lead to unexpected results. For example, suppose one issue contains the text phrase "VSX will crash" and another issue contains the phrase "VSX will not crash". A text search for "VSX will crash" will return both of these issues. This is because the words will and not are part of the reserved words list.

 Your Jira administrator can make Jira index these reserved words (so that Jira will find issues based on the presence of these words) by changing the Indexing Language to Other (under Administration > System > General Configuration).

Both
"Language[Short text]" ~ ("NO")
and 
"Language[Short text]" ~"\"NO\""
are not working.

John Funk Community Leader Jan 07, 2021

I suggest you go ahead and open a support ticket with Atlassian:

https://support.atlassian.com/contact/#/

Then please post back here what the resolution was.  

Like Helma likes this

Thanks a lot for your help.

Like John Funk likes this
0 votes

Hello Helma,

Thank you for reaching out to Atlassian Community!

Testing on my local site, I was able to replicate the same issue. Words as NO and IT doesn't return anything when using the CONTAINS operator (~).

I used the same values on a dropdown field and it works.

I believe that this is expected because they are reserved words as you mentioned in one of your replies.

There was a bug a while ago related to this issue, but it was closed as "Won't fix".

There is a workaround that I tested here and it works. Changing the indexing language of the site to "Other" will fix this issue. Go to Cog icon > System > Edit settings and change the Indexing language. 

Regards,
Angélica

Thanks Angélica.
Unfortunately the administrator is not willing to make this change.

Like Angélica Luz likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Trello

📹 Favorite Trello templates

Hello Community!  My name is Brittany Joiner and I am a Trello enthusiast and Atlassian Community Leader. In this video, I'll share my favorite Trello templates. Templates mentioned in ...

75 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you