Jira Checklist Validator

I'm trying to add the checklist validator and it as attached to the transition to DONE with the proper parameters, but it isn't preventing the user from moving the issue to DONE.  I've tried using the search function allMandatoryItemsChecked() and that returns the expected results.  

We are currently testing this plugin to see if we want to use it so I have a trial version.  Does that make a difference?  Am I missing something?

4 answers

1 vote

Hey Jean,

Can you attach a screenshot showing the validator in your "Done" transition, just to be sure that we are on the same page here?

Also, is there any stacktraces in your $JIRA_HOME/log/atlassian-jira.log file when performing this transtition?

Cheers,
Andre 

Here is the screenshot.  We did find the following error:

Line 47303: 2015-06-30 09:53:12,544 http-bio-8080-exec-5 ERROR watersje 593x81758x1 1q7zmul 10.192.165.28,127.0.0.1 /rest/orderbycomponent/latest/orderByOptions/primary [common.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: Error parsing JQL: uncheckedItem
at com.atlassian.jira.components.orderby.rest.OrderByOptionsResource.getPrimary(OrderByOptionsResource.java:151)
at com.atlassian.plugins.rest.common.interceptor.impl.DispatchProviderHelper$TypeOutInvoker$1.invoke(DispatchProviderHelper.java:205) <+18> (DispatchProviderHelper.java:100) (DefaultMethodInvocation.java:61) (ExpandInterceptor.java:38) (DefaultMethodInvocation.java:61) (DispatchProviderHelper.java:132) (DispatchProviderHelper.java:201) (ResourceJavaMethodDispatcher.java:75) (HttpMethodRule.java:288) (RightHandPathRule.java:147) (ResourceClassRule.java:108) (RightHandPathRule.java:147) (RootResourceClassesRule.java:84) (WebApplicationImpl.java:1469) (WebApplicationImpl.java:1400) (WebApplicationImpl.java:1349) (WebApplicationImpl.java:1339) (WebComponent.java:416) (ServletContainer.java:537)
at com.atlassian.plugins.rest.module.RestDelegatingServletFilter$JerseyOsgiServletContainer.doFilter(RestDelegatingServletFilter.java:178) <+1> (ServletContainer.java:795)
at com.atlassian.plugins.rest.module.RestDelegatingServletFilter.doFilter(RestDelegatingServletFilter.java:73) <+16> (DelegatingPluginFilter.java:78) (IteratingFilterChain.java:42) (ServletFilterModuleContainerFilter.java:77) (ServletFilterModuleContainerFilter.java:63) (DelegatingPluginFilter.java:78) (IteratingFilterChain.java:42) (DelegatingPluginFilter.java:70) (RestServletUtilsUpdaterFilter.java:26) (RestServletUtilsUpdaterFilter.java:40) (DelegatingPluginFilter.java:78) (IteratingFilterChain.java:42) (DelegatingPluginFilter.java:70) (ContextFilter.java:25) (DelegatingPluginFilter.java:78) (IteratingFilterChain.java:42) (DelegatingPluginFilter.java:70)
at com.atlassian.plugins.rest.module.servlet.RestSeraphFilter.doFilter(RestSeraphFilter.java:40) <+3> (DelegatingPluginFilter.java:78) (IteratingFilterChain.java:42) (DelegatingPluginFilter.java:70)
at com.atlassian.jira.components.orderby.rest.OrderByOptionsResource.getQuery(OrderByOptionsResource.java:159)
at com.atlassian.jira.components.orderby.rest.OrderByOptionsResource.getPrimary(OrderByOptionsResource.java:146)

 

The support system won't let me add another comment or question until tomorrow because "I don't have 25 points", so I'll keep editing this.

 

We are using JIRA 6.3.8 and Agile 6.7.4.  I've tried changing states in both the Agile board and on the issue itself and it works both ways even though the checklist isn't completed.  We are using the validator as the issue goes to Done.  It can do this from any other state.  

Screen Shot 2015-06-30 at 11.31.10 AM.png

Hi Jean,

What version of JIRA and Agile are you using? I will try it out but it has always worked before. Also, do you use the validator for a specific workflow state?

Yves

Hi Jean,

I just tried the validator in JIRA 6.4.7 and its works as expected. Sorry if this sound stupid but did you:

  • Publish your workflow? (It happened to me so many times smile)
  • Is the published workflow applied to the project?
  • Are you triggering a transition on which the validator applies to?
  • Are some items in the checklist mandatory? Your validator is only for mandatory items. You may want to set it to all to see.

Regards,

Yves

 

There are no stupid questions. I've been asking the same ones myself. Yes, it is the active workflow and the workflow for the project. I added the validater to the transition from any state to Done, but it lets me move to Done anyway. I tried setting it to all items and it still lets me move the issue to Done. Open to any other ideas. I'm tempted to delete this checklist and try with a new one.

You may effectively remove the add-on and try to re-install it. Also, did you try with a blank project to see if it is the same behavior. I am as lost as you as the cause for it not to function. You are the first one to report the validator not functioning. However, looking at the error logged, it does not come from Checklist per say but it seems to have to do with sorting components and options. Do you have any default sorting in place. Also, I assume that you do have options set for the Checklist. Try without to see if it works.

Just FYI - I got it working. We still had a different checklist add-on installed (Kanoah) that we were testing as well. It wasn't being used, but was still enabled. I disabled that one and the validator started working. Thanks for all of your help.

Thanks Jean! Just to let you know, I am currently developping Checklist V3 which will have a much better User Experience similar to the Kanoah one but better :-

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Sarah Schuster
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

13,173 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you