Jira Automation not copying the contents of a custom field when trigger by a user other than author?

Vinay Sharma April 2, 2024

I have created a Jira automation rule to copy the contents of a custom field from an Epic to its underpinned Task(s). When I am creating a Task, the contents of the custom field are copied.

However, when any other user is adding a task via + button inside the Epic, the contents of the custom field are not copied.

What could be the reason? How to fix it?

2 answers

0 votes
John Funk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 2, 2024

Hi Vinay,

Try looking at the Audit Log for the rule to see if it is firing with the users do a manual create. Also, please post a screenshot of your rule. 

0 votes
Stephen Wright _Elabor8_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
April 2, 2024

Hi @Vinay Sharma 

Is there an audit log error for the rule when others create issues using the "+" button?

It would also be beneficial to see the detail of your rule.

If you could provide these details (screenshots would be great), we can then look into what might be causing this :)

Ste

Vinay Sharma April 2, 2024

Thanks @Stephen Wright _Elabor8_ Here is the screenshot of the rule:

Automation Rule.png

Audit Log

Audit Log.png

 

Suggest an answer

Log in or Sign up to answer