Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,513
Community Members
 
Community Events
176
Community Groups

Jira Automation Issue

I have created a new jira automation for round robin assigning tasks but it seems to never trigger. Also when I try to turn off or on any automation, or make changes to existing rules I get an unspecific error. I've attached the rule and how it's configured, and as you can see from the audit log, it's never triggering. I've also added a photo of the error i'm getting when trying to turn off a rule or edit a rule.

I'm using: Jira service desk 4.2.4

Jira Software: 8.2.4

Jira Core: 8.2.4

3 answers

1 accepted

0 votes
Answer accepted

error.PNGRound Robin rule.PNG

Was this resolved, if so any advice? I'm currently experiencing the same issue.

How was this resolved?  I'm having the same issue but when the rule creates a issue.  The moment I add a new action to an automation that is Create an Issue it can not be turned on anymore.

0 votes
Florian PEREZ Community Leader Jun 08, 2022

You should try the following solution 

https://confluence.atlassian.com/automation/upgrading-to-automation-for-jira-7-3-1055951956.html > The part 5 is a prerequisite when upgrading. 

I experienced the same problem and this have fixed my problem

The support helped a lot on this one to be perfectly honest and I hope it could help.

0 votes
John Funk Community Leader May 07, 2021

Hi Chris - Welcome to the Atlassian Community!

Can you share a screen shot of your Rule Details page? 

Does this Rule get called from another rule possibly? If so, check the box on the Details page. 

Be sure to save and publish the Rule. 

I just made this new so it should not be called by anything else.rule detail.PNG

John Funk Community Leader May 07, 2021

The only things I can think of are to change the Actor to Automation For Jira to see if this has any effect. 

And to click the Allow Rule Trigger box - again, just to see what happens. 

Any time I try to make any changes I get "an unknown error occurred. Please reload and try again" no matter what I do. Where can I view this error? 

John Funk Community Leader May 07, 2021

Just trying to click on the box and publish it causes that error? 

Yes, if I try to turn it off or on I get that error. And if I go into it to make changes i get that error

John Funk Community Leader May 07, 2021

That sounds like you need to go ahead and submit a ticket to Atlassian:

https://support.atlassian.com/contact/#/

Like Bill Sheboy likes this

Hello, I have the same problem...And I just realized it is not linked to the automation I just created. It also affects "old" automation... No automation can be updated.

I created an issue to Atlassian Support

Hi,

Is this issue resolved? 

I am also facing same issue. I just changed "Who can edit this rule" to private means I can only edit. After this change, I am facing this issue. Its not allowing to edit the rule or disable the rule.

Many Thanks

I have exact same issue as Kiran.
It is reliably reproducible after changing "Who can edit this rule".

I cannot even delete it or disable, so it is polluting my list of automation rules.
This could be a critical problem if the trigger is automatic and not desired anymore.

Sadly we could never get this to work, instead we upgraded to cloud and this fixed all our issues

Like John Funk likes this

It got magically fixed for me.
Not sure how or whether it was an upgrade, since I am not an admin.

John Funk Community Leader Jun 08, 2022

Ah, those are the best kinds of fixes.  :-)

Glad it is working for you. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events