Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JQL Filter "Custom text field Is not EMPTY" returns empty and not empty results

Issue Summary:

The filter "Custom text field is not EMPTY" not Working in JQL

Steps to Reproduce:

Create a custom field “Status Comment” - type Text Field (multi-line)

Create a filter "Status Comment" is not EMPTY

Expected Results:

The filter returns the results with not EMPTY values

Actual Results:

JQL shows the issue where the field is EMPTY and NOT EMPTY

The filter "Status Comment" is EMPTY is working fine

1 answer

0 votes
John Funk Community Leader Jul 12, 2021

Hi Natalia,

Can you share the exact filter that you are using? 

Hi John,

Just noticed that the default value in that field contained an empty space. that explained it! I removed it but the result is still the same. We are on Jira cloud, I cannot reindex. 

the filter is not fancy, just project = <project name> and "Status Comment" is not EMPTY

thank you,

Natalia

John Funk Community Leader Jul 12, 2021

So it still shows issue that have nothing in the "Status Comment" field? 

If you click on one of those that should not be showing up and then click into that field, is the space still there? 

Hi @Natalia Trofimov 

Are you using a team-managed project, and is that custom field defined for the project?  If so, I wonder if you could be seeing this defect: https://jira.atlassian.com/browse/JRACLOUD-76536

If not, perhaps it is this one related to this field type's editor: https://jira.atlassian.com/browse/JRACLOUD-74027

Best regards,
Bill

Like John Funk likes this

Hi Bill,

yes, I saw it.

1. the projects are not team-managed

2. I tried to change to Default Text renderer instead of WikiStyle Renderer, the outcome is the same

It looks like it is some kind of glitch. We have the same multiline text filed with the same configurations and it is used for the same issue types and the same projects and the filters (is EMPTY and not EMPTY) are working for the second custom field.

BTY, we just migrated to jira cloud from jira-server. the same filter behavior in jira-server so it is not jira-cloud related...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

🏊‍♀️ Atlympic Event: Trello

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

62 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you