Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA error 500 Edited

Hello!

 

We are having a issue. Jira (v7.3.5#73016-sha1:3e40501) gives 500 error after server reboot.

Hosting company have updated GitLab, then they rebooted the server.

Afterwards Jira shows 500 error immediately after login. 

 

Maybe you have idea what might be causing issues or how to recover it?

 

2 answers

0 votes
bitvoodoo nick Community Leader Apr 03, 2018

Error 500 is HTTP code for "Internal server error". So it can mean a lot. ;)

Are you completely unable to access Jira?

Please have a look inside the Jira Application Logs and see for "fatal" or "error" right after the startup.

Best Regards
Niklas

There is basically one exception which is thrown everytime request is made:

2018-04-03 15:29:11,120 http-nio-8082-exec-6 ERROR - [o.a.c.c.C.[.[localhost].[/].[action]] Servlet.service() for servlet action threw exception
java.lang.NoClassDefFoundError: Could not initialize class webwork.dispatcher.GenericDispatcher
at com.atlassian.jira.web.dispatcher.JiraWebworkActionDispatcher.prepareDispatcher(JiraWebworkActionDispatcher.java:205)
at com.atlassian.jira.web.dispatcher.JiraWebworkActionDispatcher.service(JiraWebworkActionDispatcher.java:142)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:729)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:230)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:165)
... 88 filtered
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:745)
bitvoodoo nick Community Leader Apr 04, 2018

This is likely to be an issue with Java. 

The error looks exactly like this one: Cannot start JIRA after fresh installation, 500 error page

This might apply to you even if it is not a fresh installation. You mentioned your hosting company updated GitLab. Ask them if they did anything to Java too.

Usually Jira uses a bundled Java Runtime Environment, but maybe you are using the System JRE?

Best Regards
Nick

Thanks for the answer, will ask them, let you know how it will end up :)

Sadly hosting provider responded that setting JAVA_HOME path did not solved the issue. As well, they tried to cleanup plugins cache and jira's work directories, but it did not helper neither. 

We can access login page. Authentication works - when you enter correct credentials you are redirected forward, but instead of dashboard, screen of death is shown. Any ideas, what might be causing it? Thanks in advance !

Did this get resolved?  I'm running to the same issue

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,375 views 22 32
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you