Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Is Not Empty not Working in JQL After Clearing It Edited

I am having an issue in JQL where I am searching for "ParagraphField" is not EMPTY and it works initially, only returning the tickets where this field is not empty. The issue is that if I then go and clear the text (select all, delete or using Jira Automation) it is still returned in the results- there doesn't seem to be a way to make the field empty again. Anyone have any ideas on how to resolve this?

4 answers

1 accepted

1 vote
Answer accepted

Turns out this is a known bug in their system. Here is the link to the ticket for voting and tracking

https://jira.atlassian.com/browse/JRACLOUD-74809

0 votes
John Funk Community Leader Nov 17, 2020

Hi Scott,

Can you share an example of the JQL query along with the results where it is not returning correctly? 

It is as simple as 'project = "project" AND "ParagraphField" is not EMPTY'. I can't really share the results as it will show our company info.

 

Run the query, nothing shows up. I add something to ParagraphField and rerun the query and it shows up as expected. I then clear the data in ParagraphField and rerun the query and the ticket is still there even though ParagraphField is now empty.

John Funk Community Leader Nov 18, 2020

No worries about not showing the data - that is expected. 

I would try to do it with an automation rule, and after you clear the field, I would do a New Action, Re-fetch issue data. 

Then hopefully when it runs, if it does not update the field you might get some hints in the Audit log for the rule. 

I tried that but it didn't make any difference, it is still not seen as empty even though the Rule ran successfully.

Screenshot 2020-11-24 120740.jpg

John Funk Community Leader Nov 30, 2020

Sorry - was out all of last week. 

So the rule runs, but it does not clear the field and you get no error message. Correct? 

@Simeon Ross  - Any thoughts? 

Simeon Ross Atlassian Team Nov 30, 2020

Hey mate.

I'm not sure if this is a search within Jira or with Automation for Jira?

It sounds like its a Jira search, so I'm not real sure. It might be an issue with indexing or caching inside Jira? The only thing I can think of to check would be that the field is allowed to be empty but if the rule is running successfully that won't be it either.

I think it could be a candidate for raising a support case.

@John Funk Yes that is correct, rules runs without error and clears the field but it still shows in the query results.

 

@Simeon Ross yes it is a query that I am trying to use to tag blockers in our board. The issue is that I add something to the field that successfully triggers, but then when I clear it, manually via the screen or via automation, and it stays marked as triggered. This behaviour is replicated by running the JQL directly, even though the field is empty it is still returning in the results for a not empty query. Based on the API it seems the value is null before it is touched and then when I clear it, it is set to "" instead of null.

If this doesn't help offer a possible solution I will get a ticket raised.

Simeon Ross Atlassian Team Dec 01, 2020

Hi @Scott Edwards,

Yeah, in this case I think you should raise this as a support ticket. It'll need some detailed investigation.

Cheers,

Simeon.

I'll raise a ticket and see how I go.

 

Thanks for your help.

Like John Funk likes this

I have queried the API and the field value is different on the field I have clear "customfield_11660": null vs the field on an issue that I have never edited "customfield_11660": "". I have tried setting the value to null using the API to no avail- the value doesn't go back to null even though the update call is successful (204). It would seem that empty is checking for null and not empty string in this instance and that is causing the issue and I can't see a way of getting this back to null.

@Scott Edwards @Simeon Ross

Hi, did this get resolved in the end? I am having exactly the same problem.

Unfortunately, it is a known bug in their system. Here is the link to the ticket for voting and tracking

https://jira.atlassian.com/browse/JRACLOUD-74809

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

7,121 views 8 28
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you