Installation of Service Desk fails on JIRA Software 7.6.1 Edited

At "System" -> "Applications" I tried to install the JIRA Service Desk Application. But it failed.

Message:

An unexpected error occurred. Refer to the logs for more information.

 

In the Log:

2017-12-17 17:56:22,425 UpmAsynchronousTaskManager:thread-3 INFO alexd 1075x3278x1 yjw7fs 10.0.8.6 /rest/plugins/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] No plugins found to be installed
2017-12-17 17:56:22,462 UpmAsynchronousTaskManager:thread-3 INFO alexd 1075x3278x1 yjw7fs 10.0.8.6 /rest/plugins/1.0/ [c.a.plugin.manager.DefaultPluginManager] Updating plugin 'com.atlassian.servicedesk.application' from version '3.9.1' to version '3.9.1'
2017-12-17 17:56:22,466 UpmAsynchronousTaskManager:thread-3 INFO alexd 1075x3278x1 yjw7fs 10.0.8.6 /rest/plugins/1.0/ [c.a.plugin.loaders.ScanningPluginLoader] Removed plugin 'com.atlassian.servicedesk.application'
2017-12-17 17:56:25,685 UpmScheduler:thread-1 WARN alexd 1050x2123x1 13gmnia 10.0.8.6 /rest/plugins/self-update/1.0/ [c.a.upm.pac.PacClientImpl] Update check request may take longer because of the number of add-ons

 

 

2 answers

0 vote
Gonchik Tsymzhitov Community Champion Dec 17, 2017

Hi Alexander! 

As a short term attempt to fix it, you could try clearing the add-on cache.

  • Stop JIRA
  • Go to <JIRA installation>/work
  • Move the files in that directory to a backup directory somewhere outside the installation (your home directory is a good one).  Do NOT delete the directory itself, only the content.
  • Go to <JIRA data>/plugins
  • remove the .osgi-plugins and .bundled-plugins directories to somewhere safe (your home again?)
  • Start JIRA and monitor the logs for errors

 

 

Cheers,

Gonchik Tsymzhitov

0 vote

Hello, 

thanks for the suggestion. Just as additional information.

I had the problem already last week. So I did a new attempt yesterday.

I did a new installation of JIRA Software 7.6.0 (installer on Linux CentOS) and imported a backup of the database (and restored attachments, logos, avatars).

After that i did a upgrade to JIRA Software 7.6.1.

-> Then I used the Button at "System" -> "Applications" and tried to install the Service Desk application. 

Then the same problem occured.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Sarah Schuster
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

13,144 views 15 13
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you