Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,368,358
Community Members
 
Community Events
168
Community Groups

In Log work, clicking "Date Started" date picker causes form validation to fail

If you don't change the "Date Started" value or if you change the value manually (typing it in), the work gets logged successfully. However, as soon as you click the calendar button and pick a date, you cannot submit the form (validation error: "You must specify a date on which the work occurred."), even if you change the date back to the original value. Anyone seen this? (On Jira 9.0.0.)

3 answers

1 accepted

0 votes
Answer accepted
Charlie Misonne Community Leader Sep 06, 2022

Hi Paul,

Were you able to solve this? I have the same issue when using Jira in Dutch.

The date picker does not add a dot behind the month and not between a.m. or p.m.

I still have to test it myself but I think you can solve it by changing to a date format that doesn't use the abbreviated months (so MM instead of MMM) and use a 24h format.

This is the related bug report: https://jira.atlassian.com/browse/JRASERVER-62590

Hi @Charlie Misonne and @Florian Bonniec,

I was finally able to get back to looking at this. We were using English UK language pack. I switched it to English US and now people are able to log work again. Thank you both for the help!

Cheers,

Paul

Like Charlie Misonne likes this
Charlie Misonne Community Leader Sep 06, 2022

Hi Paul,

Ok! Good to know.

I will test the date format change myself and post whether it worked here.

But I'm glad switch to US English already solved your case.

Oops. Please ignore :)

0 votes

Hi @Paul Monk 

So entering a date works but selecting one from the calendar do not ?

 

Do you notice a different format between the date that is set by default and the one displayed when selecting one with the calendar?

 

It may be related to this issue.

 

https://confluence.atlassian.com/jirakb/invalid-date-when-trying-to-log-work-on-issue-in-jira-297667653.html

Hi @Florian Bonniec 

Yes. Initially, when opening the Log work dialog, the start date shows "08/Aug./22 3:38 p.m." If the current date is picked from the calendar, it changes to "8/Aug./22 01:43 AM" (leading zero, stripped, actual timestamp is AM instead of PM and upper-case). 

I checked that issue you mentioned and the language is a bit vague. It says "Verify the key jira.date.picker.java.format corresponds with the key jira.date.picker.javascript.format"

Does "correspond" mean "the same"? The values I have for the java/javascript formats are very different. Which one is the correct one?

jira.date.picker.java.format: d/MMM/yy

jira.date.picker.javascript.format: %e/%b/%y

I've never seen that javascript format syntax. Is that documented somewhere? 

Thanks,

Paul

@Paul Monk 

 

I don't think you have an issue with jira.date.picker.java.format and jira.date.picker.javascript.format.

But you should look at  jira.date.time.picker.java.format and jira.date.time.picker.javascript.format

 

Can you share the value you have for both of this params ?

Yes, I realized that. I was too lazy to go back to update the reply. But both will have similar issues.

jira.date.time.picker.java.format: dd/MMM/yy h:mm a

jira.date.time.picker.javascript.format: %e/%b/%y %I:%M %p

Are these "%e/%b/%y %I:%M %p" placeholders described somewhere?

I doubt we've ever edited any of these and this feature was working for us. (Last time it was used, we were on an a prior release, an 8.x.x I believe.) Was there a change in Jira in this area?

Thanks,

Paul

Weird it looks fine to me.

You can find the meaning for the % in this link https://devhints.io/datetime

Like Paul Monk likes this

Yeah, it's odd. Thanks for the help and the links! I'll log a case.

Cheers,

Paul

It seems to be a date format issue to me.

Can you add a screenshot with the popup without the issue and one with the issue ?

Like Charlie Misonne likes this

Popup when it first opens:

jira 01.jpg

 

After picking the date from the calendar:

jira 02.jpg

But it's not how the date displays that's the problem. It's that it causes a validation error. Even if you change it to look like the first screen shot, it still does not validate. 

jira 03.jpg

Not sure how to solve this issue but I think the expected format in order to be a valid date is 8/Aug./22 04:32 a.m.

Is your JIRA installed with "en_AUS" or "Dutch" or Netherland ?

 

A bit weird but it seems to be related to this issue but it's a Cloud issue.

https://jira.atlassian.com/browse/JRACLOUD-71304

 

What if you change your profile to Nederlands then log time, it should display the right format if it's the issue above.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS

Atlassian Community Events