Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I am trying to upload files on our Jira however is giving me internal service error.

I am trying to upload files on our Jira however is giving me internal service error. What I've done so far is to delete old audit log files to check if that is a storage issue but is not.

I've tried restarting jira several times still same result.

 

 

3 answers

0 votes
Ismael Jimoh Community Leader Apr 24, 2021

Hi @Danisse Mae Gador 

For this, I’ll start with the following:

  1. Open your browser developer console and upload the file check the error returned in console and network as these could help narrow down if it’s an application, network or similar issue
  2. If you know when you added the attachment, go to your <application Home>/log/Atlassian-jira.log file to see what error is being thrown while it attaches the file.

Share the errors seen with us or search google and we will be happy to help further.

Regards

Hi @Ismael Jimoh 
Thank you for the response. However, when I check in the logs it is not reflected there which is weird for me.

What I've done so far is to delete old log files to free up the memory since I was thinking that this might be a storage-related issue. Also, tried restarting the server multiple times but no luck.

When I ran the developer tools, here's the POST log that I am able to see

MicrosoftTeams-image (2).png

Ismael Jimoh Community Leader Apr 24, 2021

Hi @Danisse Mae Gador 

That is quite weird as this makes it harder to discern.

Can you check that:

  1. Your user who starts the Jira service can write to the <JIRA Home>/data/attachments directory? Better yet the whole <JIRA Home> directory.
  2. Does this impact only your user or all users on the application

To be honest, I am not sure why once again. If we could see an error in the log, it’ll definitely help.

Hi @Ismael Jimoh 

 

Yes it has the appropriate permissionMicrosoftTeams-image (3).png

Also, this is happening to all of our users

Ismael Jimoh Community Leader Apr 25, 2021

This is quite odd then. 

I am unsure what else could lead to this behaviour.

In the end, this is making a rest API call and a 403 means either the user doesn’t have the permission to add an attachment or if adding attachments is disabled.

45C4480B-6756-4A1F-A140-9D1A87BA4E65.png

Could you go to the advance attachments as described here: https://confluence.atlassian.com/adminjiraserver/configuring-file-attachments-938847851.html

Ensure Allow attachments is turned on at least here and if it is also try increasing the limit if it is less than 10MB(the application would normally throw attachment size limit exceptions here but just to rule out this as well).
Also as suggested by @Suhas Patil @ensure JIRA is running by the JIRA user.

Are you getting issues only for attachments? or any other operations too?

Permissions look alright but have ensured the user running the Jira service is jira and not root or any other user? Pls check that first by ps command.

One more question, while deleting the log files, was Jira down or running? 

You might wanna try restarting Jira by deleting the cache, it is also possible that the cache is broken but that happens when you delete stuff while Jira is running.

Issue has been resolved. Thanks!

Ismael Jimoh Community Leader Apr 26, 2021

@Danisse Mae Gador  Can you elaborate here what the root cause was as often others who experience the same can find this useful?

Thanks.

Actually, we don't know the root cause we just tried restarted the entire EC2 instance and not just the JIRA Service and it worked.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
VERSION
8.5.5
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Staying organized with Jira: best practices for a better project management

Project managers know this problem: A “mountain of work” lays in front of you, and you don’t know how and where to tackle them. Different to-dos lie ahead, but just one task after the other can be ha...

242 views 2 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you