I am configuring mail server in jira but it gives the error like : An error has occurred with send

I already configure JNDI in server and install the certificate on server

Please help me to resolve the issue

 

Thank You

1 answer

0 votes

Hi Aarti,

Can you let us know what the full error message says? We need to know what the exact problem is before we can suggest a resolution for you.

When you provide these details, can you also let us know what type of email server you're setting up? This will help us to properly advise you.

Regards,

Shannon

Hi Shannon,

Full Error is 

An error has occurred with sending the test email:
com.atlassian.mail.MailException: javax.mail.AuthenticationFailedException: 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbum
534-5.7.14 m2yDp2QojoHxWBnIUbum9CL0DmtiMuLq5b9W4ue2HbRCHW2_VW58tvl1UHUEF2dNGyyLBi
534-5.7.14 gcDuk08YMW558FJVt_15sXJ1NIJqC94FrPjiVeIRskyOFPK7gIRsEtBWz8tqK_3-M7G5ar
534-5.7.14 V3bz18vv1CI_Voy0tNJxothPsbmL7E5vXwEYFmWn4COCE9gNXyTGZjoTA6hHOPOZQLi44x
534-5.7.14 TchWnLlbs-AV9IClxnTYrelPyRYpE> Please log in via your web browser and
534-5.7.14 then try again.
534-5.7.14 Learn more at
534 5.7.14 https://support.google.com/mail/answer/78754 t71sm643278pfg.115 - gsmtp

We are trying to configure gmail mail server but somehow it shows the above issue

Thank You

Aarti,

Did you have a look at the support link that Google mentions in the error? Generally when I see this error I would suggest the same:

Step 2: Try these troubleshooting steps

  • Update your email client to the latest version.
  • Use an App Password: If you use 2-Step Verification, try signing in with an App Password.
  • Allow less secure apps: If you don't use 2-Step Verification, you might need to allow less secure apps to access your account.
  • If you recently changed your Gmail password, you might need to re-enter your Gmail account information or completely repeat your Gmail account setup on your other email client.
  • If the tips above didn't help, visit https://www.google.com/accounts/DisplayUnlockCaptcha and follow the steps on the page.
  • The email client's sign-in method might be insecure. Try signing in directly on the Gmail app.

Let me know if you have any trouble!

Regards,

Shannon

Hi Shannon,

Yes I already see the support link that google mention and I already enable the less secure app but still it shows the same error

I followed all the steps that google mention in that link still error is same

Please do the needful

Thank You

Aarti,

In those troubleshooting steps, there are a total of 6 suggestions to try. At least 4 of them will help in this situation.

Could you let me know how those went? I would try the 2nd one first, to create an app specific password. I've had success with this one myself in the past.

Let me know how it goes.

Regards,

Shannon

Hey Shannon,

Yes I know there is a 6 suggestion and I already followed this all suggestion

1 - Update your email client to the latest version.

Already it is the latest version

2 - Use an App Passpword: If you use 2-Step Verification, try signing in with an App Password.

This is for if you are using 2 step verification then you need app password , but i am not using 2 step verification

3 - Allow less secure apps: If you don't use 2-Step Verification, you might need to allow less secure apps to access your account.

I followed this step and allow less secure app

4 If you recently changed your Gmail password, you might need to re-enter your Gmail account information or completely repeat your Gmail account setup on your other email client.

I also followed this step , I changed the password and again setup the gmail account information in jira

5 If the tips above didn't help, visit https://www.google.com/accounts/DisplayUnlockCaptcha and follow the steps on the page.

I also followed this step , enable captcha

Kindly give me the reason after doing all this step why I am getting this error?

Thank You

Hey Shannon,

Yes I know there is a 6 suggestions and I followed all the suggestion

1 - Update your email client to the latest version.

It is already the latest version

2 - Use an App Password: If you use 2-Step Verification, try signing in with an App Password.

I am not using 2 step verification so there is no need to use app password

3 - Allow less secure apps: If you don't use 2-Step Verification, you might need to allow less secure apps to access your account.

I followed this step and already enabled less secure apps

4 - If you recently changed your Gmail password, you might need to re-enter your Gmail account information or completely repeat your Gmail account setup on your other email client.

I also follow this step , change the password and again setup all the information in jira

5 - If the tips above didn't help, visit https://www.google.com/accounts/DisplayUnlockCaptcha and follow the steps on the page.

Also done this step

Please tell me why I am getting this error after following all this step ?

Thank you 

Hey Shannon,

Yes I know there is a 6 suggestions and I followed all the suggestion

1 - Update your email client to the latest version.

It is already the latest version

2 - Use an App Password: If you use 2-Step Verification, try signing in with an App Password.

I am not using 2 step verification so there is no need to use app password

3 - Allow less secure apps: If you don't use 2-Step Verification, you might need to allow less secure apps to access your account

I followed this step and already enabled less secure apps

4 - If you recently changed your Gmail password, you might need to re-enter your Gmail account information or completely repeat your Gmail account setup on your other email client.

I also follow this step , change the password and again setup all the information in jira

5 - If the tips above didn't help, visit https://www.google.com/accounts/DisplayUnlockCaptcha and follow the steps on the page.

Also done this step

Please tell me why I am getting this error after following all this step ?

Thank you 

Hi @Aarti Parikh

I have had a similar problem before when trying to setup a gmail account within my Jira instance.   In my case I did actually have 2-step authentication and I also had to enable the 'less secure apps' option.   But even after I did this, I still found that my instance would create this kind of error at first.

I kept getting an automated warning in gmail that some 'suspicious activity' on this account from IP xxx.xxx.xxx.xxx ( <---- the public IP of my server running Jira).   However once I was able to login to this mail account via my browser and click on these warning, I was able to indicate to Google that this is not suspicious activity and that in fact I wanted this application to use this account.  Only after I did this was my Jira instance able to use this gmail account correctly.  

If you setup a recovery account for this email address (some other email address) you might have received a warning message from Gmail there.  You might have to click through that message in order to confirm that your account is not being compromised by some malicious application.  So you might have two different accounts to login to in order to confirm with Gmail that this is a legit connection.

Try to login to this account in your browser, and then in a separate tab try going to https://myaccount.google.com/security-checkup

This site might tell us more about why this isn't working in Jira.   I would expect this site to indicate that 'Third-party access' is currently enabled, but that is needed for this application to be able to use this account.  My concern is to learn if Google has actively flagged this account with an sort of security limitations that might be in turn preventing Jira from using this account as expected.

If you have completed all those steps, I would like to take a closer look at the specific error message you are seeing in the Jira logs when this happens.

Is there a reason you are using the JNDI option to set this up?

In my options, even when using SECURE_SMTP option in Jira, I did not need to use JNDI to do this, nor did I need to add any certificates to Jira's truststore.  So I am curious if perhaps your configuration is different in some way.  In my case my settings were:

Protocol : Secure_smtp

host name  smtp.gmail.com

port 465

timeout 10000

TLS (not enabled)

username: (my accounts full email address such as example@gmail.com )

change password option (not checked)

and my JNDI location field is empty

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

329 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot