Error when creating a subtask

Lizzeth Campos February 19, 2024

Hi Community!

When trying to create a subtask, Jira shows the following errors. Are you getting these too?

* When creating a subtask directly from the main task, it shows: "We couldn't create the subtask. Error server response: 500" 

* When creating a subtask going to a filter, clicking on the ellipsis, and selecting the "create subtask" option, it shows: "Couldn't create the issue. We're having some trouble creating the issue. Refresh the page and try again".

However, after refreshing the page, it still doesn't work. 

See images attached.

Thank you!

1 answer

0 votes
Walter Buggenhout
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 19, 2024

Hi @Lizzeth Campos and welcome to the Community!

I don't see any images attached. But apart from that, the error message you refer to is not very informative indeed.

Most commonly, failure to create issues is often linked to required fields not being present where you are trying to create the issue. e.g. when you are trying to do this inline from a task, you only have the summary field available. If you have set the description or additional fields as required (for your sub-tasks), Jira says no.

So, check your field configuration or any workflow validators that may require you to fill out fields that you don't see when you are trying to create your sub-tasks and get rid of them. Hopefully that is what is happening here.

Hope this helps!

Lizzeth Campos February 19, 2024

Hi @Walter Buggenhout Thank you! I'll check the field configuration. For now, see the images attached, corresponding to the original message.

Lizzeth Campos February 19, 2024

Error server response 500 when creating a subtask directly from the main task.png

Lizzeth Campos February 19, 2024

1Creating a subtask from the filter.png2Creating a subtask from the filter_Form.png3Error when creating a subtask from the filter.png

Like Walter Buggenhout likes this
Walter Buggenhout
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 19, 2024

There's nothing conclusive on the screenshots, @Lizzeth Campos. The only things I can see, is that this is a custom made sub-task issue type and that it apparently has a lot of fields on it (I notice there are several tabs on the issue create screen). In the first screenshot, you can see the scenario I was describing. The other scenario is different, but it does happen that a required field is simply not on the screen create screen at all. So, the hypothesis that there may be a required field missing still stands, although I can't tell you which one it might be.

Like Lizzeth Campos likes this
Lizzeth Campos February 22, 2024

Hi @Walter Buggenhout Thank you :) we did a clean-up in our custom fields, and we deleted one that was being used in a post function of that workflow. We weren't using the field in our screens, but we had it in a workflow. After deleting that post function, it worked again. Thankfully we didn't need that post function anymore.

 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events