Difficulties Building .war file from source

I've been trying to build JIRA 7.5.1 as a .war file to deploy as a web application in my j2ee container.

So I am following this.


However, I am running into several issues with the build.

It typically fails when trying to download/configure node/yarn.

I tried this...

to Edit jira-project\package.json - to exclude preinstall/postinstall

according to https://community.atlassian.com/t5/Jira-questions/JIRA-Software-


it got me further...

And I ran into this 

[ERROR] error An unexpected error occurred: "https://npm-private.atlassian.io/@atlassian%2fstylelint-config-jira-fecq/-/@atlassian%2fstylelint-config-
jira-fecq-1.0.1.tgz: connect ETIMEDOUT".
[INFO] info If you think this is a bug, please open a bug report with the information provided in "c:\\Projects\\atlassian-jira-software-7.5.1-source\

Another post referred to this as a build issue on atlassian end that doesn't allow me to access npm-preivate.atlassion.io


Can you provide some direction here?    

As an alternative....  I just need a jira .war file.    If there is a way to do it without building from the source code.  That may work too.


2 answers

0 vote

Hi Cory,

I understand you are wanting to deploy a WAR installation of Jira.  That becomes much more difficult for Jira 7 versions since Atlassian officially discontinued all support for WAR installations back in 2016.   We announced that this change back in 2014, (you can find the previous announcements on end of support announcements about this).  That post explains why Atlassian stopped providing this as a means to deploy Jira.  The short answer is that it makes installations much more difficult and in general provides a negative product experience.

That said there are Atlassian prepared WAR packages for Jira 6.4.x and before that you can still find in the Jira Downloads Archive. I am not sure if these older versions would suffice in your case or not.

I hope this helps,


0 vote

Hi Cory,

I just found a related ticket to this problem in https://jira.atlassian.com/browse/JRASERVER-66224   It appears that this inability to build Jira from the current source is a bug. 

I would recommend watching this bug ticket for updates to this. 


Appreciated.    A .war installation in my existing J2EE container is a lot easier for me to maintain and monitor with my other apps.    

Looking forward to this fix.

Suggest an answer

Log in or Join to answer
Community showcase
Bridget Sauer
Published Mar 05, 2018 in Jira Software

Jack Graves: Real Ale enthusiast with a knack for Jira Software implementation

@Jack Graves first caught our eye with his incredible breakdown of what, in his opinion, can make or break a Jira software implementation. (Read his thoughts on this thread)! In this followup Sh...

66,475 views 4 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot