Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Database: JIRA couldn't connect to your database

I'm having an issue with Jira using mysql. It was working flawlessly but now after migrating this stack to a different machine it quit working. I can login just fine to mysql with the credentials in dbconfig.xml. The host and port are returning mysql login prompts when I telnet to them so I'm stumped as to where I need to look next to solve this problem.

2 answers

1 accepted

1 vote
Answer accepted

Try replacing "localhost" with 127.0.0.1, that's worked for me a couple times.

 

Also, can you check the logs for Jira and post what message you're getting?

Logs just kept saying there was something wrong with the credentials. I erased the password and repasted it and worked. Very odd because, it was the same password, nothing changed. I rsynced everything on this machine directly from the other working machine.

Andy Heinzer Atlassian Team Oct 23, 2018

Thanks for posting back with your solution.  That is very strange.  The database password would be stored in cleartext in the dbconfig.xml file.  I'm curious if perhaps you were changing between operating systems (Windows to Linux or vice versa) and if these two operating systems were using different character encodings for certain characters.

Without revealing your database credentials, does your username/password for the database contain any special characters?   Anything aside the common characters of A-Z, a-z, 0-9, !@#$%^&*()-_;',. character sets?

1 vote
Andy Heinzer Atlassian Team Oct 23, 2018

MySQL is the one supported database for Jira that Atlassian cannot bundle the database driver for (due to licensing restrictions).   Instead you, as the admin of your system, have to download this jdbc driver separately from MySQL's site and copy this .jar file into your $JIRAINSTALL/lib/ folder and restart Jira, before Jira can make any connections to that database type.

This is explained in the Connecting Jira to MySQL database documentation.

Also when you download the driver, make sure you get the JDBC Connector/J 5.1 version, and not the 6.x or 8.x jdbc driver versions.  Jira won't work with these newer database/drivers yet.

mysql-connector-java-5.1.34-bin.jar already exists in this directory.

This really helped thanks,

I had upgraded my DB from 5.7 to 8 and didn't update the .jar and when I did, poof, it worked

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase

The benefits of using Jira in different departments

Jira is a great tool to use across different departments. Forget that paperwork – switch to Jira and get that tasks done smoothly. Marketing Jira allows for a complete digital transformation of you...

95 views 0 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you