Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Dashbords don't load Edited

Hi,

I have a fresh Jira Software 8.2.2 installation running on CentOS7 / Tomcat8.

Right after login, when the main Dashboad should be loaded, most of the times, it don't load. When I refresh it still don't load. However, sometimes it does work.

When the dashboard don't load, the console output does not show any  Error, only some Deprecated warnings.

When I check Tomcat logs in catalina.out after some time the following Error is printed:

WARNING [ContainerBackgroundProcessor[StandardEngine[Catalina]]] org.apache.catalina.valves.StuckThreadDetectionValve.notifyStuckThreadDetected Thread [http-nio-8000-exec-9] (id=[28]) has been active for [120,172] milliseconds (since [7/22/19 1:53 PM]) to serve the same request for [https://jira.xpto.net/secure/Dashboard.jspa] and may be stuck (configured threshold for this StuckThreadDetectionValve is [120] seconds). There is/are [1] thread(s) in total that are monitored by this Valve and may be stuck.

This behavior occurs with all users using different web browsers.

Any suggestions to solve this problem?

 

2 answers

1 vote
Andy Heinzer Atlassian Team Jul 24, 2019

Hi,

Sorry to hear about this problem.  That error message you posted might be related to the dashboards not loading, but it is not providing enough information yet for us to clearly understand the cause here.

You mentioned this is a new installation.  Could you let us know more about the system resources that are available to this server running Jira?  For example,

  • number of CPU cores
  • CPU speed
  • amount of system memory (RAM)
  • And is this server dedicated solely to running Jira?  Or does it have other intensive process applications like a postgresql database or alike?

Additional logs might be needed in order to troubleshoot this further.   I am curious to learn if perhaps the problem could be related to whether or not the Jira application is able to communicate freely with the base URL set for the site itself.   Not all environments are setup to permit this, and Jira needs to be able to do this to function correctly.  When that happens you can also get other errors appearing when the dashboard does load such as those explained in the KB How to fix gadget titles showing as __MSG_gadget.

That KB has several possible causes for that specific problem, all of them revolve around different scenarios that prevent the Jira application from reaching the base URL set for Jira over the network in some manner (routing, SSL, reverse proxy configuration, outbound proxy configuration, etc, all of them potentially can cause the site to appear to load to external users, but in turn can cause other problems when the application can't reach that address.)

Please let me know the results and we can try to work the problem from there.

Andy

Good answer for me. Deploying Jira Server in Azure drove me to similar situation and the problem was self communication form the VM to the public DNS entry (just a telnet to the external URL from the Jira Server hanged on trying status). Adding a firewall rule at Azure level solved the issue.

Like Andy Heinzer likes this

Just in case this is helpful:

I ran into a similar issue building a test instance, with the Dash hanging/not loading.

Error in logs: SNIP StuckThreadDetectionValve.notifyStuckThreadDetected etc

On closer inspection the problem seemed to be that I had created an entry in /etc/hosts pointing the base url for jira at the external ip of the instance (the same as production) but in the test environment there must be some security group /firewall rules around that external interface. I pointed the base url at the internal ip instead and it loads up and works; this is all I need for testing. 

I thought it might be helpful for someone else, maybe.

Onwards,

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,635 views 22 33
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you