Dashboard keeps getting corrupted. Shows “Sleep 3 &” Edited

I have to keep deleting odd dashboards in order to get my system dashboard to function. The system dashboard will show “; x || sleep 3 &” in a few spots with empty gadgets, but when I delete this dashboard my original working dashboard will come back to life. I need to remove this spontaneous dashboard every day and it’s annoying and worrisome for anything else that might come later spontaneously.

1 answer

0 vote

Any other symptoms in Jira?  Sluggish performance?  Have you gone into system to review things such as Java Virtual Memory?

Can you tell us a bit more about the environment?  Platform, Jira Version, etc?

Any other symptoms in Jira?

No

Sluggish Performance?

No

Have you gone into the system to review things such as Java virtual memory?

Yes, everything is at least 26% Free, except for the metaspace which shows 0%.

All integrity and health checks pass in JIRA.

Can you tell us a bit more about the environment?

JIRA 7.5.1, this was also happening on 7.5.  I try to stay updated to the latest version.

Centos server(latest updates & upgrades) with PostgreSQL database. I update the server daily. The server shuts down every morning for 2 hours for backups. I only use the Java prepackaged with the software. I also use an Apache Web Server with a certbot SSL certificate on the Web Server. 

I first noticed the issue around the time I installed the Git Integration for Jira plug-in, but even after uninstalling that, the same issue still comes up.

Metaspace is as designed to be functioning at 100%

Can we take a look at the default dashboard settings?  Lets see if there's any gadgets that weren't removed from the git integration add-in.

https://confluence.atlassian.com/adminjiraserver071/configuring-the-default-dashboard-802592292.html

Everything there looks normal. No Git remaining. Less than 20 gadgets. Perhaps this is a database issue?

These two dashboards keep getting spontaneously created. When I deleted these, everything goes back to normal....

1C190F59-8602-4099-8918-3886FCF3CC81.jpeg

Could be, Almost curious enough to reinstall the plugin and see what happens.

Other than that, I'd suggest escalating it up to atlassian with a support request.

I selected restore defaults under Manage Dashboards, then ran the vacuum and indexing directly from the database. I tried that before without selecting restore defaults first. 1 day so far without issues. Too soon to see if that fixed it.

lets see what happens.  Curious to hear about day 2 for you as well.

It’s still working fine. No additional issues. 

Awesome!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Sarah Schuster
Posted Mar 28, 2018 in Jira Software

Can a company’s culture make or break agile adoption?

Can a new-to-agile team survive and thrive in a non-agile culture? If so, what advice would you give to those trying to be agile in a non-agile culture? What's the key(s) to success? Share your thoug...

13,534 views 16 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you