It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Custom statuses don't appear in column configuration

Jon Abad Aug 01, 2013

Hi all,

We've been working to implement GH and so I've created a custom workflow scheme and attached it to my project.

This was done in a test environment and then imported the workflow XML into the production env.

Here are some of my statuses:

  • Open
  • Reopened
  • Ready
  • In Dev
  • In QA
  • In Acceptance

statuses

The issue is that when i look in the board configuration, the statuses are not found in the "unmapped statuses" column or any of the actual columns.

Link to full size: http://screencast.com/t/5MQKOWyl1u

columns

What do i need to check?

2 answers

1 accepted

1 vote
Answer accepted
Nic Brough [Adaptavist] Community Leader Aug 01, 2013

Have you associated the workflow with your project (via the workflow scheme)?

The GH screenshot is showing that the you're using the default workflow (or similar) for the project(s) in it.

Jon Abad Aug 01, 2013

Hi Nic,

Yes, i associated the workflow via the workflow scheme and am able to move stories into the new statuses.

Once i put it into the Ready status, the story falls off the board as the status is unmapped.

Nic Brough [Adaptavist] Community Leader Aug 01, 2013

Ok, that's expected, but now you have at least one issue in the new status, can you check the column config again and see if it's still definitely not there?

Jon Abad Aug 01, 2013

No, it doesn't change the available status to map.

Nic Brough [Adaptavist] Community Leader Aug 02, 2013

One last thing I can think of, and then I'm stuck. The definition of your board - is it for just this one project? If not, then could you (temporarily) create a board that looks at this project and no others? Then see if that has all the status?

Jon Abad Aug 03, 2013

Yes, the filter being used is just for one project.

When i make a new board for that project, all of the statuses are available so there must be some issue with the order of operations from creating the board and importing the workflow.

Nic Brough [Adaptavist] Community Leader Aug 04, 2013

Sounds like you've hit a bug to me. I'd report this to Atlassian.

For what it;s worth, I've just tested my main installation with exactly this scenario and the new status I added appears in the "unmapped" column straight away. Hence my instinct that it's a bug.

Jon Abad Aug 04, 2013

I've come to the same confusing conclusion, i'm filing with Support now.

Thanks for the help!

1 vote
Jon Abad Aug 03, 2013

Yes, the filter being used is just for one project.

When i make a new board for that project, all of the statuses are available so there must be some issue with the order of operations from creating the board and importing the workflow.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Jira Software

How to prevent the propagation of unused project schemes, workflows & screens in Jira software

Atlassian ranks project attributes as the third most important factor impacting performance in the category of data. It’s not surprising, since project attributes are precisely the rules used to ma...

1,378 views 1 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you