Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,742
Community Members
 
Community Events
168
Community Groups

Created Child issue fails to get linked to Epic

When I create a child issue from an epic, the issue is not linked to the epic and Is only seen in the backlog and not in the epic. I then cannot assign the epic to the child issue to link them. This used to work about 2 weeks ago.

1 answer

0 votes

Hello @Adam Bako 

Welcome to the community.

Are you working with a Company Managed project or a Team Managed project?

Exactly what steps are you taking to create the child issue from the Epic? Are you viewing the Epic and choosing the Child Issue option? Are you highlighting the Epic in the backlog Epic Pane and then using the Create Issue option in the backlog issue list section? Or some other method? Are you adding an issue to an Epic from a Roadmap?

What is the evidence that the child issue is not getting linked to the parent epic?

Have you reviewed the history of the child issue to see if it is getting linked to the epic, and then getting unlinked?

You say you can't assign it to the Epic after that. What methods have you tried for assigning the issue to the Epic, and what have been the results of those attempts? Are you getting an error?

Hi @Trudy Claspill 

 

1. Company Managed project

2. Steps:

  • View Epic
  • click "Add a child issue"
  • filling in the issue name
  • clicking "create"

After this I see it in the child issue, but if I click on the issue the Epic Link of the issue is "None". If I refresh the page of the Epic, the issue disappears from the list of child issues and I can only see it in the issues list. Therefore I conclude the child issue is not being linked to the parent epic.

3. I cannot see the issue in the epic. The issue has "none" as "epic link"

4.  I tested it again and all I see in the history is "Adam Bako created the Issue August 25, 2022 at 7:23 PM"

5. I tried to go to the issue and click on the none to change it, but nothing happens, i cannot click it. I cannot find a way on the internet to actually assign an issue a parent epic. 

@Adam Bako 

That is all good information. Thank you.

This is a puzzler.

I thought this might be caused by the Epic Link being missing from the Create screen for that type of issue. I tested that out in my own system, but the child issue did still link to the epic and remained linked after I refreshed the page. Just to double check that on your system, if you click the Create button in the menu bar and select the same type of child issue to create, do you see the Epic Link field in the Create Issue dialog?

Other things that might cause this is an Automation Rule that is unlinking the child issue from the Epic after creation, or possibly a post-function on the workflow. You may need to work with Project Admins or Jira Admins to check those items.

@Trudy Claspill 

When I use the menu bar create button I do see the Epic Link and when I specify the Epic and create, it is created and no errors are shown. But when I go to the created issue it shows that Epic Link is None and I cannot see the issue in the epic.

I talked with a project admin and even when we turned off automations it does not work.

 

Could you please provide me a list of permissions I need to create an issue for a parent epic? Maybe I got some permissions revoked on accident and I do not have all of them. We noticed that I did not have the Edit Issues role, but even after my Admin turned it back on I still run into the same problem. But even if i missed some permissions I would hope to get some error message...

Also, has there been any updates to Jira and issues that could have caused this? Because as far as my Admin knows no-one revoked any privileges from anyone.

In a Company Managed project there are not permissions that are specific to types of issues.

First, you need the Browse Projects permission to have any access to the project at all.

Next you need the Create Issues permission to be able to create a brand new issue.

Next you need the Edit Issues permission to be able to Edit Issues that already exist.

I'm not sure if it applies specifically to the link between Epics and Child Issues, but there is also a Link Issues permission. I know that would be required to create generic likes between issues. It may also be required to create the Epic/Child relationship. I don't have a way to test that out currently.

There are other permissions that impact you ability to do specific things with an issue, like assign a user, edit a comment, and so on, but the above are the ones that would or might impact adding a child issue to an Epic.

I don't believe there have been any Jira Cloud updates recently that would've affected the details of Permission Schemes. Depending on how the Permission Schemes are set up, your permissions on a specific project could've been changed by

- a Jira Admin changing which Permission Scheme was assigned to the project

- a Jira Admin changing the users/groups/roles assigned specific permissions within the Permission Scheme assigned to the project

- A Project Administrator changing the Project Roles to which you have been individually assigned

- an administrator (could be Jira or your AD administrator) changing the user groups to which you belong.

Hi @Trudy Claspill Ill discuss this with my admin to check if all of them are on.

 

I was looking through further posts on the community and found this where in the solution the person can:

  • Select Project
  • Select Issue Type
  • Select Parent Issue

and when i use the move I only see:

  • Select Project
  • Select Issue Type

Has this functionality been removed from move or is it an indicator that some permissions are setup wrong?

 

I also found this issue opened since 2016 Are there any actual plans to fix it?

The other post you found was specific to moving a sub-task type of issue, . You are not dealing with a sub-task so that solution does not apply.

I can't speak to the plans of Atlassian to address the issue you found, as I am not an Atlassian employee. I'm just another user/administrator of Jira systems.

Oh wow, I thought you were. Well then I really appreciate your help here, thanks for all your time. I'm still trying to get those permissions validated

Most of the people in this community are just other users of Jira. If somebody from Atlassian responds, you'll see "Atlassian Team" next to their name. There are also members who are employed by companies that have apps in the Atlassian Marketplace, and they will sometimes have "Marketplace Vendor" after their name.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS

Atlassian Community Events