Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't install new license for Jira

I have installed a new version of JIRA on a new server and want to run against my old database. When I go to the JIRA webpage I get a page entitled.

Confirm New Installation

http://bcsb-cnx-a.als.lbl.gov:8080/secure/ConfirmNewInstallationWithOldLicense.jspa

 

When I enter the license and hit proceed, I get an error saying the username or password is incorrect. I'm using my atlassian login and password which works when i login to https://www.atlassian.com/

1 answer

1 accepted

0 votes
Answer accepted

Your server is not using your Atlassian account for login, your login to www.atlassian.com is irrrelevant.

You need to log in with an account that was in use in your "old database" 

OK. Thanks for the information. Here is the problem, I was using Crowd as an account server.  I'm guessing that is my problem. Is there some documentation for that? Can I create a local admin user somehow?

Thanks for any help !

Ok, it's quite likely that your system is still trying to use a crowd-provided account and not being able to reach crowd means it can't.

Best bet at this point is recovering an internal account - https://confluence.atlassian.com/jirakb/restore-passwords-to-recover-admin-user-rights-972329273.html

Thanks for your help! Made some progress but not quite there. I was able to configure the crowd files:

atlassian-jira/WEB-INF/classes/crowd.properties

atlassian-jira/WEB-INF/classes/seraph-config.xml

And tell Crowd to allow connections from the new host.

Once I did that, I was able to load my new license successfully.

At that point I thought I was good but unfortunately after restarting Jira i'm still not allowed to login. Any ideas?

Um, I'm a bit confused.  The doc I pointed to was about getting access via a local account, it had nothing to do with Crowd.

What happens when you try the local admin recovery account method?

I understand your confusion. That makes two of us...

I tried to get the new instance running with crowd. This required updating the license. I was successful in doing this by configuring Crowd and using my admin account. Once I restarted Jira, I couldn't login again with the same account. 

If I undo the Crowd changes and make the internal account change, I can login with the recovery_admin account but I don't see any of the old "issues".

I think it might be ok now. I re-indexed. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Trello

🏊‍♀️ Atlympic Event: Trello

Hello Community!  Quick disclaimer: We are running a contest on Community (The Atlympics!) from July 23rd - August 8th of 2021. If you are interested in participating in this contest (prizes! ...

119 views 1 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you