Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bulk Upload for Due Dates is failing every time i load tasks to JIRA

I am uploading the bulk tasks to JIRA using Excel and i am not seeing the Due Date i gave on excel every time i load the excel. Format i am providing on excel is 'YYYY-MM-DD. Please help

1 answer

0 votes
Fazila Ashraf Community Leader Nov 19, 2018

Hi @Vamsi Krishna Vendhoti

 

Refer to the documentation in https://confluence.atlassian.com/adminjiraserver072/importing-data-from-csv-829827152.html , make sure you give the right format in Date format in import file

 

Specify the date format used in your CSV file. Use the syntax that complies with the Java SimpleDateFormat.

Thank You Fazila.. I am using Zephyr Test Case Importer Utility to load the tasks there i am using the due date field that is given in above format and it is giving me issue ( Not loading the value at all)

Fazila Ashraf Community Leader Nov 19, 2018

Are there errors in the log file?

Could you share a sample date and the exact date formatter you used?

no errors reported , all other column data is loading except the Due Date data.

 

I am using this format '2018-11-22 as it was loading in the same format earlier correctly.

Fazila Ashraf Community Leader Nov 19, 2018

So sample date is 2018-11-22 and the date formatter you specified in the wizard is YYYY-MM-DD ?

Yes with a  ' before the date format. :) not sure i think it was only accepting like that before not NOW :(

Tue Nov 20 11:56:32 IST 2018 Unable to add testcase ending at rowNumber - 3. Error:Unexpected response code: 400

 

i am seeing this error while loading but data got loaded without a due date ..

Fazila Ashraf Community Leader Nov 22, 2018

Could you just try YYYY-MM-dd  as the format and let me know ?

Note that the d are small case and no '

I tried Fazila but in vain.. Not sure whats happening. i tried every format.. Sometime back it was working fine. I think after we moved to ON PREMISES it started to give me this issue.

Any options left with you?

Fazila Ashraf Community Leader Nov 26, 2018

Did you check whether a normal csv import works fine with this date format?

If it is happening only with zephyr import, then zephyr support might be able to shed some light.

I am also facing a similar issue today. I have exported a .csv file of a specific project. In my project, certain issue types have a "Due Date" field.  When I try to import that .csv file in the new blank project, it throws me error that:

The issue can't be created due to the error/s [ Due date is required. ]

 

while importing I have added due date as 02/04/21 5:58 a

Where I am wrong ?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Bitbucket Smart Commits vs. Genius Commits - What's the difference?

If you already heard about Smart Commits in Bitbucket, know that you just stumbled upon something even better (and smarter!): Genius Commits by Better DevOps Automation for Jira Data Center (+ Server...

106 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you