Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Blank page when viewing Service Desk Permissions Scheme on Jira Server 8.3.1 Edited

We have recently upgraded from Jira Server 8.2.0 to 8.3.1.

We have since found that our Service Desk is inaccessible to any users who do not have access to the project through Jira Server. Their browsers show 500 errors, which the returned XML shows as:

IllegalAccessException: no access here at com.prontop.v4.managers.DesignManager.getDesignContext_MustBeCalledInServiceDeskContext

If I attempt to browse the permissions scheme that governs the Service Desk, I get a blank page. The XML shows a 500 error:

java.lang.NullPointerException at com.atlassian.jira.permission.management.ManagedPermissionSchemeHelperImpl.buildGrants

I have restored our pre-upgrade database on a separate server and installed 8.2.0 to view the working permissions scheme. I can see that the the Service desk customer – portal access option is missing from the 8.3.1 system. If I attempt to create a new permissions scheme on the upgraded system, this option is not available to me.

I have found this article which describes this problem:

https://confluence.atlassian.com/jirakb/when-granting-permissions-the-service-desk-customer-portal-access-permission-is-missing-966051663.html

In our instance, the error in atlassian-jira.log is:

[n.java.ao.sql] Exception executing SQL update <ALTER TABLE JIRASchema.AO_54307E_SERVICEDESK ALTER COLUMN PROJECT_KEY NVARCHAR(255)>
com.microsoft.sqlserver.jdbc.SQLServerException: The object 'df_AO_54307E_SERVICEDESK_PROJECT_KEY' is dependent on column 'PROJECT_KEY'.

The resolution in this article is :

Remove the variations from the table structure. It may be necessary to use a fresh installation on a test instance, to determine what the correct, default structure is for your specific database type and version.

I need some help with this solution as I'm unsure what to do with it.

We're running Jira on SQL Server 2017 in SQL Server 2012 compatibility mode.

 

Edit:

I ran the command outlined at the end of this article which suggests removing the 'sd.customer.portal.only' entry from the scheme permissions of the database.

https://confluence.atlassian.com/jirakb/nullpointerexception-on-editing-permission-scheme-826891686.html

When the server came back up after a reboot, I browsed the broken permissions scheme and got this message offering to fix them.

JSD permissions fix prompt.png

I chose this option which led to a new permissions scheme being created. However, if I try to open the newly-created scheme, I get the blank screen again. My browser console shows this 500 error, which is the same as before.

status><status-code>500</status-code><stack-trace>java.lang.NullPointerException at com.atlassian.jira.permission.management.ManagedPermissionSchemeHelperImpl.buildGrants(ManagedPermissionSchemeHelperImpl.java:367) at com.atlassian.jira.permission.management.ManagedPermissionSchemeHelperImpl.lambda$generatePermissionSchemeBean$4(ManagedPermissionSchemeHelperImpl.java:249)

So the problem persists. I can see from rolling back and re-running the upgrade that this fault is triggered by the 8.3.1 upgrade. Unfortunately, rolling back the upgrade is no longer an option for us.

Any suggestions would be welcome.

2 answers

1 accepted

0 votes
Answer accepted

Hello Steve,

Sorry to hear you are facing this problem.

Indeed, it seems your problem is happening because the Service desk customer - portal access role is still being used in your instance for some project that is not a Service Desk, or some lack in the application is not identifying your current project as a SD project.

I would recommend you to do the following:

1 - Create a backup of your instance

2 - Check if your Service Desk application is up to date (4.3) with your JIRA Core installation (8.3)

3 - Perform the steps to remove sd.customer.portal.only again in the database:

  1. delete from schemepermissions where perm_type = 'sd.customer.portal.only';
    

4 - When the red warning appears, ignore it for now and check if any projects from JIRA Core or Software are also using one of the Permission Schemes as your service desk project. If it is, create a new permission scheme for them without the Service desk customer - portal access role. Optionally, you can copy the permission schemes of your Service desk project and only remove the Service desk customer - portal access role.

5 - If step 4 does not help, try to manually add the Service desk customer - portal access to the correct places, instead of following the red warning. This will help you to identify which permissions must be causing the error.

Let me know if the steps above worked for you.

Hi Petter,

Thanks for your reply.

I suspect this is our problem. 

https://jira.atlassian.com/browse/JSDSERVER-6521

I have run this on a test system and it fixed the issue. 

Thanks,

Steve

Thank you for sharing it, Steve.

I encountered the issue too. It was fixed with a server restart.

Hope it helps for anyone else who encountered this.

Another possibility is https://confluence.atlassian.com/jirakb/blank-page-displayed-when-editing-a-permissions-scheme-in-jira-server-826891686.html

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Software

How to create Jira issus from Excel file?

When to use CSV importer When managing your processes in Jira, there are many occasions where you need to create a lot of tasks. Creating them one by one will cost you a lot of time and effort and i...

4,610 views 22 33
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you