Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Automation rule for new issue won't fire -- no conditions and all it does is write to audit Edited

I originally tried to create a rule based on 'Story' Issuetype but I've found in troubleshooting that even a rule that writes an audit log entry on any issue creation does not fire (that's all that is in the rule...no conditions at all). Is there a known problem with this right nowScreenshot from 2021-02-12 17-25-42.pngScreenshot from 2021-02-12 17-27-13.png

1 answer

Hi @Greg Bridges  -- Welcome to the Atlassian Community!

For problems with rules, it can help the community give you ideas if you post an image of your rule and of the audit log.  Would you please post those?  Thanks!

And, to check for current incidents impacting the automation rules you can look at these two status pages:

https://status.automationforjira.com/

https://status.atlassian.com/


Best regards,

Bill

Thanks Bill...I edited my post and did that. TBH there was so little to the rule and nothing was added to the audit so I didn't think it would be very helpful :-)

Okay, I tried that simple rule too and it fired, no problem.

Is this a rule within a single project, or a global rule for a specific project?  (You may only do the second kind if you are a site admin.)

And, let's try this:

  • Create a rule with a manual trigger that also just writes an audit log entry
  • Navigate to an issue, and run the rule from the lightning bolt icon

That should rule out any permissions issues if the rule works.

Screenshot from 2021-02-12 17-47-37.png

 

Yep, that one worked. I've created both global and project-specific versions of the rule with no success. I'm a Org & Site Admin, so I wouldn't have thought it could be a permissions problem. I even changed the one above that fired from manual to on Issue creation and it didn't fire when I created the issue.

-Greg

I also added one to fire on Issue Updated and that one fired as well.

Okay, that is curious.  If this is still happening I recommend submitting a defect to Atlassian to take a look: https://support.atlassian.com/contact/#/

Once you learn more from them, please post back here so the rest of the community can hear what happened.  Thanks!

Like Greg Bridges likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

7,120 views 8 28
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you